This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1284221 - kernel 4.2 breaks intel video Broadcast RGB video
kernel 4.2 breaks intel video Broadcast RGB video
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-21 20:43 EST by Tom Horsley
Modified: 2016-01-07 20:26 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-07 20:26:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 92206 None None None Never

  None (edit)
Description Tom Horsley 2015-11-21 20:43:31 EST
Description of problem:

When the apparent gauze layer over the screen made me think I was getting cataracts after installing the 4.2 kernel for fedora, I went searching and found this:

https://bugs.freedesktop.org/show_bug.cgi?id=92206

The xrandr --set 'Broadcast RGB' Full command no longer works for my hdmi
output, and the culprit seems to be some bug no one ever tracked down in kernel 4.2 which is fixed in kernel 4.3.

Can we get kernel 4.3 for fedora 22/23 someday soon please?

Version-Release number of selected component (if applicable):
kernel-4.2.6-200.fc22.x86_64

How reproducible:
100%


Steps to Reproduce:
1. try to run xrandr command to set various 'Broadcast RGB' values
2. see absolutely no screen flicker or change in appearance
3. boot a 4.1 kernel and you can notice the difference

Actual results:
changing 'Broadcast RGB' property with xrandr has no effect.


Expected results:
changing 'Broadcast RGB' to full make the scales drop from my eyes :-).

Additional info:
Comment 1 Josh Boyer 2015-11-23 07:37:01 EST
F23 will get 4.3.y around the time 4.3.1 or 4.3.2 comes out.
Comment 2 Tom Horsley 2015-12-11 13:46:29 EST
OK, 4.3.1 is out:

http://lkml.iu.edu/hypermail/linux/kernel/1512.1/01644.html

Is it ready yet? :-).
Comment 3 Josh Boyer 2015-12-11 13:58:41 EST
No.  F22 won't be rebased until after the new year.
Comment 4 Tom Horsley 2016-01-07 20:26:25 EST
Just tried the updates-testing 4.3.3-300.fc23 kernel in my fedora23 partition, and it is wonderful! I can run my xrandr script now and lift the gauze layer off my screen. It is now safe for me to make fedora 23 my default boot partition. I might as well mark this as closed.

Note You need to log in before you can comment on or make changes to this bug.