Bug 1284260 - VMware environment cannot be added as external provider.
VMware environment cannot be added as external provider.
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity urgent (vote)
: ovirt-3.6.1
: 3.6.1.3
Assigned To: Arik
Nisim Simsolo
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-22 08:32 EST by Nisim Simsolo
Modified: 2016-02-10 14:24 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 08:28:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: blocker+
mgoldboi: planning_ack+
tjelinek: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 49581 master MERGED webadmin: support vmware provider without proxy Never
oVirt gerrit 49582 master MERGED webadmin: support vmware provider without data-center Never
oVirt gerrit 49630 ovirt-engine-3.6 MERGED webadmin: support vmware provider without proxy Never
oVirt gerrit 49631 ovirt-engine-3.6 MERGED webadmin: support vmware provider without data-center Never
oVirt gerrit 50044 refs/tags/ovirt-engine-3.6.1 ABANDONED webadmin: support vmware provider without proxy Never
oVirt gerrit 50045 refs/tags/ovirt-engine-3.6.1 ABANDONED webadmin: support vmware provider without data-center Never
oVirt gerrit 50072 ovirt-engine-3.6.1 MERGED webadmin: support vmware provider without proxy Never
oVirt gerrit 50073 ovirt-engine-3.6.1 MERGED webadmin: support vmware provider without data-center Never

  None (edit)
Description Nisim Simsolo 2015-11-22 08:32:49 EST
Description of problem:
When trying to add VMware as external provider from webadmin, the "Add" page -> "ok" and "test" buttons are not functioning at all.

Version-Release number of selected component (if applicable):
rhevm-3.6.0.3-0.1.el6 (3.6.0-20)

How reproducible:
100%

Steps to Reproduce:
1. From webadmin, navigate to external providers (left pane) -> add.
2. from type dropbox select "VMware" and set name, vCenter, ESXi, data center, username and password.
3. Click "ok" or "test" buttons.

Actual results:
Nothing happens (also engine.log is not showing anything)

Expected results:
VMware environment should be added to external providers.

Additional info:
Comment 1 Tomas Jelinek 2015-11-25 06:42:24 EST
This looks like an FE exception - please attach the FE logs (javascript console of the browser) from time when you simulate and provide the exact browser and version of it you used.
Thanx
Comment 2 Nisim Simsolo 2015-11-29 10:17:11 EST
I'm using Firefox 41.0.2, but it also happens on different browsers.
Java console log of the event:

too much recursion <unknown>
uncaught exception: java.lang.IllegalStateException: This widget's parent does not implement HasWidgets <unknown>
too much recursion <unknown>
too much recursion jquery-1.11.3.min.js:4:14899
too much recursion <unknown>
uncaught exception: java.lang.IllegalStateException: This widget's parent does not implement HasWidgets <unknown>
too much recursion <unknown>
too much recursion <unknown>
too much recursion <unknown>
too much recursion <unknown>
too much recursion <unknown>
too much recursion <unknown>
too much recursion <unknown>
Sun Nov 29 17:12:17 GMT+200 2015 
SEVERE: Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) 
 __gwt$exception: <skipped>: zab(...) is undefined
	at Unknown.ms(Unknown Source)
	at Unknown.us(Unknown Source)
	at Unknown.e3(Unknown Source)
	at Unknown.h3(Unknown Source)
	at Unknown.s2(Unknown Source)
	at Unknown.Im(Unknown Source)
	at Unknown.Sm(Unknown Source)
	at Unknown.g$(Unknown Source)
	at Unknown.Km(Unknown Source)
	at Unknown.t5e(Unknown Source)
	at Unknown.YVe(Unknown Source)
	at Unknown.YXe(Unknown Source)
	at Unknown.Yt(Unknown Source)
	at Unknown.au(Unknown Source)
	at Unknown._t/<(Unknown Source)
	at Unknown.ty(Unknown Source)
	at Unknown.Z4e(Unknown Source)
	at Unknown.Zll(Unknown Source)
	at Unknown.t5e(Unknown Source)
	at Unknown.YVe(Unknown Source)
	at Unknown.XVe(Unknown Source)
	at Unknown.WXe(Unknown Source)
	at Unknown.Yt(Unknown Source)
	at Unknown.au(Unknown Source)
	at Unknown._t/<(Unknown Source)
	at Unknown.anonymous(Unknown Source)
Caused by: com.google.gwt.core.client.JavaScriptException: (TypeError) 
 __gwt$exception: <skipped>: zab(...) is undefined
	at Unknown.Pbq(Unknown Source)
	at Unknown.ccq(Unknown Source)
	at Unknown.Tbq(Unknown Source)
	at Unknown.bcq(Unknown Source)
	at Unknown.jll(Unknown Source)
	at Unknown.myk(Unknown Source)
	at Unknown.B$(Unknown Source)
	at Unknown.C2(Unknown Source)
	at Unknown.s2(Unknown Source)
	at Unknown.Im(Unknown Source)
	at Unknown.Sm(Unknown Source)
	at Unknown.g$(Unknown Source)
	at Unknown.Km(Unknown Source)
	at Unknown.t5e(Unknown Source)
	at Unknown.YVe(Unknown Source)
	at Unknown.YXe(Unknown Source)
	at Unknown.Yt(Unknown Source)
	at Unknown.au(Unknown Source)
	at Unknown._t/<(Unknown Source)
	at Unknown.ty(Unknown Source)
	at Unknown.Z4e(Unknown Source)
	at Unknown.Zll(Unknown Source)
	at Unknown.t5e(Unknown Source)
	at Unknown.YVe(Unknown Source)
	at Unknown.XVe(Unknown Source)
	at Unknown.WXe(Unknown Source)
	at Unknown.Yt(Unknown Source)
	at Unknown.au(Unknown Source)
	at Unknown._t/<(Unknown Source)
	at Unknown.anonymous(Unknown Source)
 3D3715EC390EF8179A7EF851FB5EC9A5.cache.html:24007:11772
Comment 3 Arik 2015-12-02 08:00:33 EST
if you specify 'any data center' or not specifying the proxy host, it doesn't work.
it is easy to fix that but for now you must select a data center and a proxy host.
Comment 4 Red Hat Bugzilla Rules Engine 2015-12-03 04:08:59 EST
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 5 Red Hat Bugzilla Rules Engine 2015-12-06 03:31:22 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 6 Red Hat Bugzilla Rules Engine 2015-12-07 09:09:22 EST
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 7 Red Hat Bugzilla Rules Engine 2015-12-10 21:27:14 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 8 Nisim Simsolo 2015-12-22 07:30:36 EST
Verified: 
rhevm-3.6.1.3-0.1.el6

VMware can now be added as external provider, also without selecting DC and proxy host.
Comment 9 Sandro Bonazzola 2015-12-22 08:28:00 EST
oVirt 3.6.1 has been released and bz verified, moving to closed current release

Note You need to log in before you can comment on or make changes to this bug.