Bug 1284315 - mod_asis disappears without notice from httpd in Fedora 23 despite the fact that Apache still appears to support it
mod_asis disappears without notice from httpd in Fedora 23 despite the fact t...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Kaluža
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-22 20:41 EST by Jonathan Kamens
Modified: 2016-01-06 09:58 EST (History)
6 users (show)

See Also:
Fixed In Version: httpd-2.4.17-4.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-06 09:58:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2015-11-22 20:41:25 EST
mod_asis was removed from the httpd build in Fedora 23.

The ChangeLog entries for this offer no explanation for why.

There is nothing in the release notes about it.

The module still appears to be supported by Apache.

Please put it back or document why it was removed.
Comment 1 Joe Orton 2015-11-23 05:58:17 EST
We stopped loaded that module by default since 2006 (Fedora Core 5) and AFAICT we have had precisely zero bug reports, so I presume that matches the number of users for that module.  Yeah, sorry, it should have gone in the release notes.
Comment 2 Jonathan Kamens 2015-11-23 08:21:22 EST
Or maybe those of us who were using it when you removed it from httpd.conf simply left the reference to it in our own httpd.conf files and happily continued to use it until you stopping shipping it. Just sayin'.
Comment 3 Michael Catanzaro 2015-12-04 06:06:22 EST
(In reply to Jonathan Kamens from comment #2)
> Or maybe those of us who were using it when you removed it from httpd.conf
> simply left the reference to it in our own httpd.conf files and happily
> continued to use it until you stopping shipping it. Just sayin'.

WebKit uses mod_asis for layout tests; we load it in our own httpd.conf. I am not sure how to workaround its removal from Fedora. I guess we will need to either build Apache in a copr and modify our install-dependencies script to automatically enable that copr when using Fedora, or else add a Fedora-specific conditional in our jhbuild environment to build Apache from source when running in Fedora, as I don't want to require WebKit developers to use another distro.

Of course I would really prefer to use system Apache instead. Was it causing any problems to build it?
Comment 4 Joe Orton 2015-12-09 11:26:31 EST
No problem, it was the only module which was built but no LoadModule included (even commented).  I'll restore it, with commented-out LoadModule in 00-optional.conf.  Thanks for the feedback!
Comment 6 Joe Orton 2015-12-09 12:09:36 EST
Package: httpd-2.4.17-4.fc23
Build: https://koji.fedoraproject.org/koji/buildinfo?buildID=704433
Comment 7 Michael Catanzaro 2015-12-09 13:51:42 EST
Thanks Joe! I will point WebKit developers to that new build.
Comment 8 Joe Orton 2015-12-10 07:15:54 EST
We can push this to updates but it looks like 2.4.18 will be out RSN so I'd prefer to wait for that and push a rebase (with this change included).
Comment 9 Harald Reindl 2015-12-12 05:22:02 EST
well, our own packages just build all what we need on most servers static and anything else as loadable module inclduing the new mod_http2

./configure \
 --disable-dependency-tracking \
 --prefix=%{_sysconfdir}/%{name} \
 --exec-prefix=%{_prefix} \
 --bindir=%{_bindir} \
 --sbindir=%{_sbindir} \
 --mandir=%{_mandir} \
 --libdir=%{_libdir} \
 --sysconfdir=%{_sysconfdir}/%{name}/conf \
 --includedir=%{_includedir}/%{name} \
 --libexecdir=%{_libdir}/%{name}/modules \
 --datadir=%{contentdir} \
 --enable-layout=Fedora \
 --enable-mpms-static=prefork \
 --with-mpm=prefork \
 --enable-mods-shared=all \
 --enable-mods-static="alias allowmethods auth_basic auth_digest authn_core authn_file authz_core authz_groupfile authz_host authz_user autoindex deflate dir env expires filter headers log_config mime ratelimit remoteip reqtimeout rewrite setenvif socache_shmcb unique_id unixd version" \
 --enable-nonportable-atomics \
 --enable-allocator-uses-mmap \
 --enable-proxy \
 --enable-cache \
 --enable-disk-cache \
 --enable-cgi \
 --enable-authn-anon \
 --enable-authn-alias \
 --enable-pie \
 --enable-ssl \
 --with-installbuilddir=%{_libdir}/%{name}/build \
 --with-apr=%{_prefix} \
 --with-apr-util=%{_prefix} \
 --with-pic \
 --with-pcre \
 --with-ssl \
 --disable-dtrace \
 --disable-ldap \
 --disable-lua \
 --disable-access-compat \
 --disable-charset-lite \
 --disable-distcache \
 --disable-imagemap \
 --disable-session \
 --disable-suexec \
 --disable-debug


mod_actions-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_asis-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_auth_form-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_authn_anon-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_authn_dbd-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_authn_dbm-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_authn_socache-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_authz_dbd-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_authz_dbm-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_authz_owner-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_buffer-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_cache-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_cache_disk-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_cache_socache-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_cgi-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_data-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_dav-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_dav_fs-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_dav_lock-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_dbd-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_dialup-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_dumpio-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_echo-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_ext_filter-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_file_cache-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_heartbeat-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_heartmonitor-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_http2-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_include-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_info-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_lbmethod_bybusyness-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_lbmethod_byrequests-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_lbmethod_bytraffic-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_lbmethod_heartbeat-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_log_debug-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_log_forensic-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_logio-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_macro-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_mime_magic-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_negotiation-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_proxy-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_proxy_ajp-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_proxy_balancer-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_proxy_connect-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_proxy_express-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_proxy_fcgi-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_proxy_fdpass-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_proxy_ftp-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_proxy_html-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_proxy_http-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_proxy_scgi-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_proxy_wstunnel-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_reflector-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_request-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_sed-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_slotmem_plain-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_slotmem_shm-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_socache_dbm-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_socache_memcache-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_speling-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_ssl-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_status-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_substitute-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_userdir-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_usertrack-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_vhost_alias-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_watchdog-2.4.18-1.fc23.20151208.rh.x86_64.rpm
mod_xml2enc-2.4.18-1.fc23.20151208.rh.x86_64.rpm
Comment 10 Fedora Update System 2016-01-06 09:55:24 EST
httpd-2.4.18-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-46b611abb8
Comment 11 Joe Orton 2016-01-06 09:58:37 EST
I edited the wrong bodhi update!  This is fixed in the 2.4.18, thanks to Jan.

https://bodhi.fedoraproject.org/updates/FEDORA-2016-41d91f9c64

Note You need to log in before you can comment on or make changes to this bug.