This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1284426 - Appliances originally running 5.3.0 are using automations not present in their current release even after reset of the appliance's datastores
Appliances originally running 5.3.0 are using automations not present in thei...
Status: CLOSED DUPLICATE of bug 1284427
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.4.0
All All
unspecified Severity high
: GA
: 5.5.0
Assigned To: Greg McCullough
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 05:18 EST by Felix Dewaleyne
Modified: 2015-11-23 05:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 05:56:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diff -r -q affected_datastore_extracted non_affected_datastore_extracted.out (31.24 KB, text/plain)
2015-11-23 05:18 EST, Felix Dewaleyne
no flags Details

  None (edit)
Description Felix Dewaleyne 2015-11-23 05:18:43 EST
Created attachment 1097610 [details]
diff -r -q affected_datastore_extracted non_affected_datastore_extracted.out

Description of problem:
Appliances originally running 5.3.0 are using automations not present in their current release even after reset of the appliance's datastores

Version-Release number of selected component (if applicable):
5.4.3.1

How reproducible:
all the time

Steps to Reproduce:
1. install a 5.3.0 appliance
2. create a sample automation
3. upgrade to 5.4 using the documented path from the release notes
4. reset the datastore

Actual results:
in the ManageIQ and RedHat automations, content dating from 5.3.0 will continue to be present even after reset of the appliance datastore, such as /ManageIQ/Infrastructure/VM/Retirement/

Expected results:
the datastore of ManageIQ and RedHat are comparable to the contents of a deployed 5.4.3.1 (if 5.4.3.1 is the level the apppliance is updated to)

Additional info:
Comment 2 Felix Dewaleyne 2015-11-23 05:56:31 EST
an issue while opening this bug caused it to be duplicated - all information have been added into bz#1284427

*** This bug has been marked as a duplicate of bug 1284427 ***

Note You need to log in before you can comment on or make changes to this bug.