Bug 1284437 - Take latest kprobe/uprobe patches
Take latest kprobe/uprobe patches
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kernel-aarch64 (Show other bugs)
7.3
aarch64 Linux
medium Severity medium
: rc
: 7.3
Assigned To: Pratyush Anand
Erico Nunes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 05:39 EST by Pratyush Anand
Modified: 2016-11-03 18:16 EDT (History)
4 users (show)

See Also:
Fixed In Version: kernel-4.5.0-0.rc2.26.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 18:16:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2145 normal SHIPPED_LIVE kernel-aarch64 bug fix and enhancement update 2016-11-03 09:11:35 EDT

  None (edit)
Description Pratyush Anand 2015-11-23 05:39:19 EST
Description of problem:

Take latest uprobe and kprobe patches from mainline/under discussion on upstream.

Actual results:
No uprobe/kprobe support for RHEL7.3 which is currently tracking v4.4-rc1.

Expected results:

Tested kprobe/uprobe features for RHEL7.3.
Comment 2 Pratyush Anand 2016-01-28 12:00:02 EST
4.5-RC rebase broke uprobe implementation and patches need to be resubmitted again. So, I was wondering should this bug be moved back to assigned or a new bug be created?
Comment 3 Mark Langsdorf 2016-01-28 12:01:46 EST
I'm moving them back to assigned.
Comment 4 Mark Langsdorf 2016-02-05 11:51:33 EST
and back to modified since they've been posted and pulled into a kernel
Comment 5 Mark Langsdorf 2016-02-05 11:57:18 EST
As this bug is already in the advisory, moving it by hand to ON_QA
Comment 6 Erico Nunes 2016-08-23 10:26:47 EDT
Verified on hp-moonshot-02-c24.khw.lab.eng.bos.redhat.com, kernel 4.5.0-3.el7.aarch64. Executed basic sanity tests with kprobes and uprobes and executed /tools/perf/Sanity/basic-test-aarch64 test on it.
The only failing result in basic-test-aarch64 is test_advanced.sh which is being covered by BZ#1299021.


[root@hp-moonshot-02-c24 ~]# uname -r
4.5.0-3.el7.aarch64
[root@hp-moonshot-02-c24 ~]# echo > /sys/kernel/debug/tracing/trace
[root@hp-moonshot-02-c24 ~]# echo "p do_sys_open" > /sys/kernel/debug/tracing/kprobe_events
[root@hp-moonshot-02-c24 ~]# echo 1 > /sys/kernel/debug/tracing/events/kprobes/enable
[root@hp-moonshot-02-c24 ~]# echo > testfile
[root@hp-moonshot-02-c24 ~]# cat testfile

[root@hp-moonshot-02-c24 ~]# echo 0 > /sys/kernel/debug/tracing/events/kprobes/enable
[root@hp-moonshot-02-c24 ~]# cat /sys/kernel/debug/tracing/trace
# tracer: nop
#
# entries-in-buffer/entries-written: 6/6   #P:8
#
#                              _-----=> irqs-off
#                             / _----=> need-resched
#                            | / _---=> hardirq/softirq
#                            || / _--=> preempt-depth
#                            ||| /     delay
#           TASK-PID   CPU#  ||||    TIMESTAMP  FUNCTION
#              | |       |   ||||       |         |
            bash-2907  [006] d...  3525.681401: p_do_sys_open_0: (do_sys_open+0x0/0x214)
             cat-3000  [000] d...  3525.682677: p_do_sys_open_0: (do_sys_open+0x0/0x214)
             cat-3000  [000] d...  3525.682705: p_do_sys_open_0: (do_sys_open+0x0/0x214)
             cat-3000  [000] d...  3525.682932: p_do_sys_open_0: (do_sys_open+0x0/0x214)
             cat-3000  [000] d...  3525.682994: p_do_sys_open_0: (do_sys_open+0x0/0x214)
            bash-2907  [006] d...  3525.685128: p_do_sys_open_0: (do_sys_open+0x0/0x214)
[root@hp-moonshot-02-c24 ~]# 
[root@hp-moonshot-02-c24 ~]# echo > /sys/kernel/debug/tracing/trace
[root@hp-moonshot-02-c24 ~]# echo "p:readline /usr/bin/bash:0x89980" > /sys/kernel/debug/tracing/uprobe_events  # readline()
[root@hp-moonshot-02-c24 ~]# echo 1 > /sys/kernel/debug/tracing/events/uprobes/enable
[root@hp-moonshot-02-c24 ~]# 
[root@hp-moonshot-02-c24 ~]# 
[root@hp-moonshot-02-c24 ~]# echo 0 > /sys/kernel/debug/tracing/events/uprobes/enable
[root@hp-moonshot-02-c24 ~]# cat /sys/kernel/debug/tracing/trace
# tracer: nop
#
# entries-in-buffer/entries-written: 3/3   #P:8
#
#                              _-----=> irqs-off
#                             / _----=> need-resched
#                            | / _---=> hardirq/softirq
#                            || / _--=> preempt-depth
#                            ||| /     delay
#           TASK-PID   CPU#  ||||    TIMESTAMP  FUNCTION
#              | |       |   ||||       |         |
            bash-2907  [006] ....  3525.771431: readline: (0x489980)
            bash-2907  [006] ....  3525.771626: readline: (0x489980)
            bash-2907  [006] ....  3525.771808: readline: (0x489980)
[root@hp-moonshot-02-c24 ~]# echo > /sys/kernel/debug/tracing/uprobe_events
[root@hp-moonshot-02-c24 ~]# echo > /sys/kernel/debug/tracing/trace
[root@hp-moonshot-02-c24 ~]#
Comment 8 errata-xmlrpc 2016-11-03 18:16:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2145.html

Note You need to log in before you can comment on or make changes to this bug.