Bug 1284547 - Kernel 4.2.6: No sound cards
Kernel 4.2.6: No sound cards
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 09:56 EST by Richard Shaw
Modified: 2015-11-25 14:18 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-25 14:18:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg from 4.2.5 kernel (sound works) (67.89 KB, text/plain)
2015-11-23 22:49 EST, Richard Shaw
no flags Details
dmesg from 4.2.6 kernel (sound does not work) (65.81 KB, text/plain)
2015-11-23 22:50 EST, Richard Shaw
no flags Details

  None (edit)
Description Richard Shaw 2015-11-23 09:56:26 EST
Description of problem:
After rebooting to kernel 4.2.6 I had no sound cards. Thought it might be card specific so I tried plugging in a USB Plantronics headset but nothing happened.

Audio device for reference:

00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
	Subsystem: Gigabyte Technology Co., Ltd GA-MA770-DS3rev2.0 Motherboard
	Flags: bus master, slow devsel, latency 32, IRQ 16
	Memory at fe024000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [50] Power Management version 2
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel


Version-Release number of selected component (if applicable):
# rpm -qa | grep kernel | grep 4.2.6
kernel-headers-4.2.6-200.fc22.x86_64
kernel-tools-libs-4.2.6-200.fc22.x86_64
kernel-core-4.2.6-200.fc22.x86_64
kernel-devel-4.2.6-200.fc22.x86_64


How reproducible:
Persisted after reboot


Additional info:
Rebooting to the previous kernel, 4.2.5 fixed the problem.
Comment 1 Justin M. Forbes 2015-11-23 11:48:45 EST
Can you please post dmesg output from a fresh boot of both the working 4.2.5 and the non working 4.2.6?
Comment 2 Richard Shaw 2015-11-23 12:19:31 EST
It may take me a day or two to get that as it's my DVR system but here's some snippits from the boot log via journalctl:

w/ 4.2.6 kernel:

# journalctl -b -1 | grep alsa
Nov 22 14:51:07 calvin.localdomain kernel: audit: type=1130 audit(1448225467.899:76): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=alsa-state comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Nov 22 14:51:07 calvin.localdomain audit[1]: <audit-1130> pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=alsa-state comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Nov 22 14:51:08 calvin.localdomain alsactl[753]: alsactl 1.0.29 daemon started
Nov 22 14:51:08 calvin.localdomain alsactl[753]: /usr/sbin/alsactl: load_state:1735No soundcards found...
Nov 22 15:08:02 calvin.localdomain alsactl[753]: /usr/sbin/alsactl: save_state:1595No soundcards found...
Nov 22 15:08:02 calvin.localdomain alsactl[753]: alsactl daemon stopped
Nov 22 15:08:02 calvin.localdomain audit[1]: <audit-1131> pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=alsa-state comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'

w/ 4.2.5 kernel:
# journalctl -b 0 | grep alsa
Nov 22 15:08:58 calvin.localdomain alsactl[767]: alsactl 1.0.29 daemon started
Nov 22 15:08:58 calvin.localdomain audit[1]: <audit-1130> pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=alsa-state comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Comment 3 Richard Shaw 2015-11-23 22:49 EST
Created attachment 1097992 [details]
dmesg from 4.2.5 kernel (sound works)
Comment 4 Richard Shaw 2015-11-23 22:50 EST
Created attachment 1097993 [details]
dmesg from 4.2.6 kernel (sound does not work)

This is actually from my desktop computer not my DVR computer but the motherboards are nearly identical and have the same issue.
Comment 5 Richard Shaw 2015-11-25 12:13:26 EST
I'm pretty sure I figured it out, it's dnf being stupid. I have a conflict for some reason:

$ sudo dnf --best update
Last metadata expiration check performed 0:00:44 ago on Wed Nov 25 11:07:53 2015.
Error: package kernel-4.2.5-201.fc22.x86_64 requires kernel-modules-uname-r = 4.2.5-201.fc22.x86_64, but none of the providers can be installed

And for some reason that's stopping the following packages from being installed:

Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 kernel                        x86_64    4.2.6-200.fc22        updates     72 k
 kernel-modules                x86_64    4.2.6-200.fc22        updates     18 M

This is due to the fact I added:
installonly=kernel,kernel-devel to dnf.conf while I was running F21 as it would not allow multiple kernel-devel's to be installed. I believe this was fixed in F22 but having the option there is now causing this issue. Removing it allows kernel-modules to be installed which I believe is the root of the problem.
Comment 6 Justin M. Forbes 2015-11-25 14:18:51 EST
That would make sense. Closing this. Thanks for the update.

Note You need to log in before you can comment on or make changes to this bug.