Bug 128460 - rhn-applet-gui warning message on startup
Summary: rhn-applet-gui warning message on startup
Status: CLOSED DUPLICATE of bug 127641
Alias: None
Product: Fedora
Classification: Fedora
Component: rhn-applet   
(Show other bugs)
Version: 2
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-23 07:58 UTC by Nigel Horne
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nigel Horne 2004-07-23 07:58:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.6) Gecko/20040510

Description of problem:
When starting rhn-applet-gui this message appears on stdout/stderr:

/usr/share/rhn/rhn_applet/rhn_applet.py:362: DeprecationWarning:
integer argument expected, got float
  self.animate_timeout_tag = gtk.timeout_add(math.floor(1000 *
ANIMATION_TOTAL_TIME/len(frames)), self.animate_handler)


Version-Release number of selected component (if applicable):
rhn-applet-2.1.7-1.1

How reproducible:
Always

Steps to Reproduce:
1. Type  rhn-applet-gui&
3.
    

Actual Results:  /usr/share/rhn/rhn_applet/rhn_applet.py:362:
DeprecationWarning: integer argument expected, got float
  self.animate_timeout_tag = gtk.timeout_add(math.floor(1000 *
ANIMATION_TOTAL_TIME/len(frames)), self.animate_handler)


Expected Results:  The warning shouldn't have appeared

Additional info:

Comment 1 Sami Teemu Pesonen 2004-07-31 11:10:49 UTC
This is same as bug 127641. Patch attached to that one.

Comment 2 Daniel Veillard 2004-07-31 11:13:51 UTC

*** This bug has been marked as a duplicate of 127641 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:04:39 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.