Bug 1284646 - UI exception thrown while opening New VM dialog in user portal with certain permissions
UI exception thrown while opening New VM dialog in user portal with certain p...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.UserPortal (Show other bugs)
4.0.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.1.1
: ---
Assigned To: Tal Nisan
Kevin Alon Goldblatt
: TestOnly
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 13:21 EST by jniederm
Modified: 2017-04-21 05:50 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-21 05:50:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
rule-engine: planning_ack+
rule-engine: devel_ack+
ratamir: testing_ack+


Attachments (Terms of Use)
stack_trace.txt (3.38 KB, text/plain)
2015-11-23 13:21 EST, jniederm
no flags Details

  None (edit)
Description jniederm 2015-11-23 13:21:24 EST
Created attachment 1097808 [details]
stack_trace.txt

Description of problem:
Certain permissions settings lead to NoSuchElementException while opening New VM dialog.

Version-Release number of selected component (if applicable):
4.0 master, commit 47337ae

How reproducible:
only right after signing into UserPortal

Steps to Reproduce:
1. In webadmin: create vm with disk
2. Create template of that vm
3. Add new user grant him (only) following permissions
     * VmCreator for template created in step 2
     * VmCreator for some Cluster that is in DC that is in state 'UP'
4. In UserPortal extended: log as newly created user
5. Open New VM dialog

Actual results:
Exception is thrown to browser console, pink popup in UI.

Expected results:
New VM dialog is open and/or user is notified that permissions are insufficient/set in a wrong way.
Comment 1 jniederm 2015-11-23 13:55:54 EST
Note: The bug disappears when Storage domain is granted VmCreator permission for the new user.
Comment 2 Sandro Bonazzola 2016-05-02 06:08:53 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 3 Yaniv Lavi (Dary) 2016-05-23 09:24:21 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 4 Yaniv Lavi (Dary) 2016-05-23 09:25:46 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 6 jniederm 2017-02-21 09:55:43 EST
In Comment 0 step to reproduce 3 should state:
"Add new user grant him (only) following *additional* permissions:"
Comment 7 Kevin Alon Goldblatt 2017-03-09 15:14:30 EST
Verified with the following code:
--------------------------------------------------------
ovirt-engine-4.1.1.3-0.1.el7.noarc
rhevm-4.1.1.3-0.1.el7.noarch
vdsm-4.19.7-1.el7ev.x86_64

Verified with the following scenario:
--------------------------------------------------------
Steps to Reproduce:
1. In webadmin: create vm with disk
2. Create template of that vm
3. Add new user grant him (only) following permissions
     * VmCreator for template created in step 2
     * VmCreator for some Cluster that is in DC that is in state 'UP'
4. In UserPortal extended: log as newly created user
5. Open New VM dialog

Actual results:
Exception is thrown to browser console, pink popup in UI.

Moving to VERIFIED!
Comment 8 Kevin Alon Goldblatt 2017-03-09 15:30:47 EST
Verified with the following code:
--------------------------------------------------------
ovirt-engine-4.1.1.3-0.1.el7.noarc
rhevm-4.1.1.3-0.1.el7.noarch
vdsm-4.19.7-1.el7ev.x86_64

Verified with the following scenario:
--------------------------------------------------------
Steps to Reproduce:
1. In webadmin: create vm with disk
2. Create template of that vm
3. Add new user grant him (only) following permissions
     * VmCreator for template created in step 2
     * VmCreator for some Cluster that is in DC that is in state 'UP'
4. In UserPortal extended: log as newly created user
5. Open New VM dialog

Actual results:
No Exceptions are thrown

Moving to VERIFIED!

Note You need to log in before you can comment on or make changes to this bug.