Bug 1284726 - [abrt] xorg-x11-server-Xorg: Segmentation fault at address 0x200000
[abrt] xorg-x11-server-Xorg: Segmentation fault at address 0x200000
Status: CLOSED DUPLICATE of bug 1285137
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
abrt_hash:54cefd85f69c6b0efe3d509c44a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 21:47 EST by dosboss64
Modified: 2015-11-24 21:55 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-24 21:55:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: Xorg.0.log (37.27 KB, text/plain)
2015-11-23 21:47 EST, dosboss64
no flags Details
File: backtrace (836 bytes, text/plain)
2015-11-23 21:47 EST, dosboss64
no flags Details
File: dmesg (78.41 KB, text/plain)
2015-11-23 21:47 EST, dosboss64
no flags Details
File: dso_list (238 bytes, text/plain)
2015-11-23 21:47 EST, dosboss64
no flags Details
File: etc_X11_xorg_conf_d.tar.gz (405 bytes, application/octet-stream)
2015-11-23 21:47 EST, dosboss64
no flags Details
File: usr_share_xorg_conf_d.tar.gz (2.28 KB, application/octet-stream)
2015-11-23 21:47 EST, dosboss64
no flags Details

  None (edit)
Description dosboss64 2015-11-23 21:47:13 EST
Description of problem:
Random crashing of X.org at different times. Only log message is below from X.org log file showing a crash in "OsLookupColor". As you can see from the log file snippet I was running X.org for a while before this crash, but the crash timing is random, with random system activity.
This is a fresh load of F23, after updating to the latest patching as of 22 Nov 2015.
This problem may have been reported, I found this forum thread for F21: http://forums.fedoraforum.org/showthread.php?p=1725137
The bug referred to in the forum is: https://bugzilla.redhat.com/show_bug.cgi?id=1172232 , however this appears to point to an Intel driver issue. I am running an AMD A10-7870K APU (the new "Kaveri" chip), with 8 GPU cores ("Radeon R7 graphics") on the die. I have no secondary graphics card installed.
lspci identifies this as :
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Kaveri [Radeon R7 Graphics] (rev d4)

----------------------------------->8----------------------------------------------
[ 73066.473] (II) RADEON(0): EDID vendor "SAM", prod id 1317
[ 73066.473] (II) RADEON(0): Using hsync ranges from config file
[ 73066.473] (II) RADEON(0): Using vrefresh ranges from config file
[ 73066.473] (II) RADEON(0): Printing DDC gathered Modelines:
[ 73066.473] (II) RADEON(0): Modeline "1920x1080"x0.0  148.50  1920 2008 2052 2200  1080 1084 1089 1125 +hsync +vsync (67.5 kHz eP)
[ 73066.473] (II) RADEON(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
[ 73066.473] (II) RADEON(0): Modeline "800x600"x0.0   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz e)
[ 73066.473] (II) RADEON(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
[ 73066.473] (II) RADEON(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
[ 73066.473] (II) RADEON(0): Modeline "1280x800"x0.0   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync (49.7 kHz e)
[ 73066.473] (II) RADEON(0): Modeline "1280x960"x0.0  108.00  1280 1376 1488 1800  960 961 964 1000 +hsync +vsync (60.0 kHz e)
[ 73066.473] (II) RADEON(0): Modeline "1280x1024"x0.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz e)
[ 73066.473] (II) RADEON(0): Modeline "1440x900"x0.0  106.50  1440 1520 1672 1904  900 903 909 934 -hsync +vsync (55.9 kHz e)
[ 73066.473] (II) RADEON(0): Modeline "1600x1200"x0.0  162.00  1600 1664 1856 2160  1200 1201 1204 1250 +hsync +vsync (75.0 kHz e)
[ 73066.473] (II) RADEON(0): Modeline "1680x1050"x0.0  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync (65.3 kHz e)
[ 75668.535] (EE)
[ 75668.535] (EE) Backtrace:
[ 75668.536] (EE) 0: /usr/libexec/Xorg (OsLookupColor+0x139) [0x59afb9]
[ 75668.537] (EE) 1: /lib64/libc.so.6 (__restore_rt+0x0) [0x7faeb4019b1f]
[ 75668.537] (EE) 2: /lib64/libpixman-1.so.0 (pixman_region_selfcheck+0xc) [0x7faeb5183aec]
[ 75668.538] (EE) 3: /lib64/libpixman-1.so.0 (pixman_region_fini+0x9) [0x7faeb5183c89]
[ 75668.538] (EE) 4: /usr/libexec/Xorg (RegionDestroy+0x9) [0x458669]
[ 75668.538] (EE) 5: /usr/libexec/Xorg (SwapShorts+0x3913) [0x465993]
[ 75668.538] (EE) 6: /usr/libexec/Xorg (DeleteWindow+0x70) [0x465240]
[ 75668.538] (EE) 7: /usr/libexec/Xorg (RegisterResourceName+0x232) [0x45b2e2]
[ 75668.538] (EE) 8: /usr/libexec/Xorg (FreeClientResources+0x6c) [0x45c34c]
[ 75668.539] (EE) 9: /usr/libexec/Xorg (CloseDownClient+0x112) [0x435ea2]
[ 75668.539] (EE) 10: /usr/libexec/Xorg (SendErrorToClient+0x151) [0x436831]
[ 75668.539] (EE) 11: /usr/libexec/Xorg (remove_fs_handlers+0x453) [0x43a9e3]
[ 75668.539] (EE) 12: /lib64/libc.so.6 (__libc_start_main+0xf0) [0x7faeb4005580]
[ 75668.539] (EE) 13: /usr/libexec/Xorg (_start+0x29) [0x424ce9]
[ 75668.540] (EE) 14: ? (?+0x29) [0x29]
[ 75668.540] (EE)
[ 75668.540] (EE) Segmentation fault at address 0x200000
[ 75668.540] (EE)
Fatal server error:
[ 75668.540] (EE) Caught signal 11 (Segmentation fault). Server aborting
[ 75668.540] (EE)
[ 75668.540] (EE)
Please consult the Fedora Project support
         at http://wiki.x.org
 for help.
[ 75668.540] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 75668.540] (EE)
[ 75668.541] (II) AIGLX: Suspending AIGLX clients for VT switch


Version-Release number of selected component:
xorg-x11-server-Xorg-1.18.0-2.fc23

Additional info:
reporter:       libreport-2.6.3
executable:     /usr/bin/X
kernel:         4.2.6-300.fc23.x86_64
runlevel:       N 5
type:           xorg

Truncated backtrace:
0: /usr/libexec/Xorg (OsLookupColor+0x139) [0x59afb9]
1: /lib64/libc.so.6 (__restore_rt+0x0) [0x7faeb4019b1f]
2: /lib64/libpixman-1.so.0 (pixman_region_selfcheck+0xc) [0x7faeb5183aec]
3: /lib64/libpixman-1.so.0 (pixman_region_fini+0x9) [0x7faeb5183c89]
4: /usr/libexec/Xorg (RegionDestroy+0x9) [0x458669]
5: /usr/libexec/Xorg (SwapShorts+0x3913) [0x465993]
6: /usr/libexec/Xorg (DeleteWindow+0x70) [0x465240]
7: /usr/libexec/Xorg (RegisterResourceName+0x232) [0x45b2e2]
8: /usr/libexec/Xorg (FreeClientResources+0x6c) [0x45c34c]
9: /usr/libexec/Xorg (CloseDownClient+0x112) [0x435ea2]
10: /usr/libexec/Xorg (SendErrorToClient+0x151) [0x436831]
11: /usr/libexec/Xorg (remove_fs_handlers+0x453) [0x43a9e3]
12: /lib64/libc.so.6 (__libc_start_main+0xf0) [0x7faeb4005580]
13: /usr/libexec/Xorg (_start+0x29) [0x424ce9]
14: ? (?+0x29) [0x29]
Comment 1 dosboss64 2015-11-23 21:47:16 EST
Created attachment 1097971 [details]
File: Xorg.0.log
Comment 2 dosboss64 2015-11-23 21:47:17 EST
Created attachment 1097972 [details]
File: backtrace
Comment 3 dosboss64 2015-11-23 21:47:18 EST
Created attachment 1097973 [details]
File: dmesg
Comment 4 dosboss64 2015-11-23 21:47:20 EST
Created attachment 1097974 [details]
File: dso_list
Comment 5 dosboss64 2015-11-23 21:47:21 EST
Created attachment 1097975 [details]
File: etc_X11_xorg_conf_d.tar.gz
Comment 6 dosboss64 2015-11-23 21:47:22 EST
Created attachment 1097976 [details]
File: usr_share_xorg_conf_d.tar.gz
Comment 7 dosboss64 2015-11-24 21:55:41 EST

*** This bug has been marked as a duplicate of bug 1285137 ***

Note You need to log in before you can comment on or make changes to this bug.