Bug 1284795 - [abrt] sddm: qt_message_fatal(): sddm-greeter killed by SIGABRT
[abrt] sddm: qt_message_fatal(): sddm-greeter killed by SIGABRT
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: sddm (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Bříza
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:66eb6eb99d77252ebe26310d2e1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 04:17 EST by Oliver Sampson
Modified: 2016-05-12 01:05 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-11 09:34:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (40.13 KB, text/plain)
2015-11-24 04:17 EST, Oliver Sampson
no flags Details
File: cgroup (190 bytes, text/plain)
2015-11-24 04:17 EST, Oliver Sampson
no flags Details
File: core_backtrace (11.82 KB, text/plain)
2015-11-24 04:17 EST, Oliver Sampson
no flags Details
File: dso_list (17.57 KB, text/plain)
2015-11-24 04:17 EST, Oliver Sampson
no flags Details
File: environ (464 bytes, text/plain)
2015-11-24 04:17 EST, Oliver Sampson
no flags Details
File: limits (1.29 KB, text/plain)
2015-11-24 04:17 EST, Oliver Sampson
no flags Details
File: maps (86.80 KB, text/plain)
2015-11-24 04:17 EST, Oliver Sampson
no flags Details
File: mountinfo (3.13 KB, text/plain)
2015-11-24 04:17 EST, Oliver Sampson
no flags Details
File: open_fds (1.69 KB, text/plain)
2015-11-24 04:17 EST, Oliver Sampson
no flags Details
File: proc_pid_status (1001 bytes, text/plain)
2015-11-24 04:17 EST, Oliver Sampson
no flags Details
File: var_log_messages (3.07 KB, text/plain)
2015-11-24 04:17 EST, Oliver Sampson
no flags Details

  None (edit)
Description Oliver Sampson 2015-11-24 04:17:13 EST
Description of problem:
While logging in.

Version-Release number of selected component:
sddm-0.12.0-5.fc22

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/sddm-greeter --socket /tmp/sddm-:0-VvygWe --theme /usr/share/sddm/themes/01-breeze-fedora
crash_function: qt_message_fatal
executable:     /usr/bin/sddm-greeter
global_pid:     1394
kernel:         4.2.6-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            990

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 qt_message_fatal at global/qlogging.cpp:1578
 #3 QMessageLogger::fatal at global/qlogging.cpp:781
 #4 QSGRenderLoop::handleContextCreationFailure at /usr/src/debug/qtdeclarative-opensource-src-5.5.1/src/quick/scenegraph/qsgrenderloop.cpp:244
 #5 QSGGuiThreadRenderLoop::renderWindow at /usr/src/debug/qtdeclarative-opensource-src-5.5.1/src/quick/scenegraph/qsgrenderloop.cpp:333
 #6 QSGGuiThreadRenderLoop::exposureChanged at /usr/src/debug/qtdeclarative-opensource-src-5.5.1/src/quick/scenegraph/qsgrenderloop.cpp:422
 #7 QWindow::event at kernel/qwindow.cpp:2053
 #8 QQuickWindow::event at /usr/src/debug/qtdeclarative-opensource-src-5.5.1/src/quick/items/qquickwindow.cpp:1413
 #9 QCoreApplication::notify at kernel/qcoreapplication.cpp:1038
 #10 QCoreApplication::notifyInternal at kernel/qcoreapplication.cpp:965
 #11 sendSpontaneousEvent at ../../src/corelib/kernel/qcoreapplication.h:227
Comment 1 Oliver Sampson 2015-11-24 04:17:19 EST
Created attachment 1098082 [details]
File: backtrace
Comment 2 Oliver Sampson 2015-11-24 04:17:20 EST
Created attachment 1098083 [details]
File: cgroup
Comment 3 Oliver Sampson 2015-11-24 04:17:22 EST
Created attachment 1098084 [details]
File: core_backtrace
Comment 4 Oliver Sampson 2015-11-24 04:17:23 EST
Created attachment 1098085 [details]
File: dso_list
Comment 5 Oliver Sampson 2015-11-24 04:17:25 EST
Created attachment 1098086 [details]
File: environ
Comment 6 Oliver Sampson 2015-11-24 04:17:26 EST
Created attachment 1098087 [details]
File: limits
Comment 7 Oliver Sampson 2015-11-24 04:17:28 EST
Created attachment 1098088 [details]
File: maps
Comment 8 Oliver Sampson 2015-11-24 04:17:29 EST
Created attachment 1098089 [details]
File: mountinfo
Comment 9 Oliver Sampson 2015-11-24 04:17:31 EST
Created attachment 1098090 [details]
File: open_fds
Comment 10 Oliver Sampson 2015-11-24 04:17:32 EST
Created attachment 1098091 [details]
File: proc_pid_status
Comment 11 Oliver Sampson 2015-11-24 04:17:33 EST
Created attachment 1098092 [details]
File: var_log_messages
Comment 12 Rex Dieter 2016-05-11 09:34:49 EDT
It appears opengl isn't working with your nvidia driver, and unfortunately, not much we can do about that.
Comment 13 Oliver Sampson 2016-05-12 01:05:03 EDT
I think you mean: OpenGL isn't handling a(n error) condition thrown by the NVIDIA driver--the only way to get CUDA, y'know--and because of our not-wanting-to-work-with-proprietary-drivers fetish, we'll say that "opengl isn't working with your nvidia driver." 

Moreover, the correct answer for software handling an error is, at the very least, to exit gracefully.

Note You need to log in before you can comment on or make changes to this bug.