Bug 1284861 - Line units are measured in inch, despite of controls tools->options
Line units are measured in inch, despite of controls tools->options
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 06:08 EST by Joachim Backes
Modified: 2016-06-12 03:19 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-12 03:19:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
See my comment! (49.23 KB, application/vnd.oasis.opendocument.text)
2015-11-26 13:09 EST, Joachim Backes
no flags Details

  None (edit)
Description Joachim Backes 2015-11-24 06:08:34 EST
Description of problem:

Choosing tools->options->Libre Office writer->Mesurement: units:=centimeter, but still line width units (for example) will be measured and presented in inch units.


Version-Release number of selected component (if applicable):

libreoffice-5.0.3.2-6.fc23.x86_64

How reproducible:
always

Steps to Reproduce:
1.Draw a line
2.Select the line and press Line->Width
3.

Actual results:

Unit is shown as "
Expected results:
Unit is shon as centimeter

Additional info:
Comment 1 Caolan McNamara 2015-11-26 08:13:11 EST
hmm, seems to work fine for me.

I start in a default en_US.UTF-8 locale, draw a line, I see " for inch in the top toolbar beside the line-style dropdown, right click->line and width in inches in the line tab under "width.

Visit tools->options->writer->general and change from inch to cm and and the top toolbar updates to "cm" as does the line properties dialog.

Does e.g. Format->Page and the "Page" tab display in inches or cm ?

When you say your "press Line->Width", what widget/dialog exactly do you mean ?
Comment 2 Joachim Backes 2015-11-26 13:06:52 EST
Please forget that I spoke about a new document.

I think the problem is that the LO doc is an very old one having inch as measure unit, and despite of the fact that now my global LO writer measure unit is centimeter, it seems that the LO writer measure control has no precedence over the doc's measure units.

For testing purposes, I have attached this LO doc. Please go to page #14. The circle around the cipher "1" in the line "1 Angabe der Kommandofolge für das BS2000" is the culprit. If trying the to reset the circle's line width, then inch unit is offered, not cm unit.

After resetting the doc's measure units to cm, all is ok.
Comment 3 Joachim Backes 2015-11-26 13:09 EST
Created attachment 1099346 [details]
See my comment!
Comment 4 Joachim Backes 2015-11-27 04:44:40 EST
I have some more docs, all are LO writer docs, and all are comprising graphics (lines, circles,...). In the meantime I have the impression thatthis is the problem!
Comment 5 Joachim Backes 2016-06-12 03:19:42 EDT
By using libreoffice-5.1.4.1-2.fc24.x86_64 I get rid of all pain with the described effects.

Note You need to log in before you can comment on or make changes to this bug.