Bug 1284910 - Log spammed by Error messages about not set up Foreman
Log spammed by Error messages about not set up Foreman
Status: CLOSED DUPLICATE of bug 1260499
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core (Show other bugs)
3.6.0.1
All All
unspecified Severity medium (vote)
: ---
: ---
Assigned To: nobody nobody
Aharon Canan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 07:58 EST by Lukas Svaty
Modified: 2015-11-25 00:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-25 00:17:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Lukas Svaty 2015-11-24 07:58:12 EST
Description of problem:
When foreman is not used in engine, log is spammed by ERROR messages (see additional info), which should rather have INFO/WARNING priority.

Version-Release number of selected component (if applicable):
rhevm-3.6.0.3-0.1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Set up engine, do not set up foreman
2. See engine.log

Actual results:
Lot of error messages

Expected results:
These messages should be put as INFO messages (maybe Warning without spamming), and might be good to consider to put it to webadmin portal to alerts.

Additional info:
2015-11-24 12:36:58,942 ERROR [org.ovirt.engine.core.bll.host.provider.foreman.SystemProviderFinder] (ajp-/127.0.0.1:8702-7) [] Failed to find host on any provider by host name 'example.com'
2015-11-24 12:36:59,670 ERROR [org.ovirt.engine.core.bll.host.provider.foreman.SystemProviderFinder] (ajp-/127.0.0.1:8702-4) [] Failed to find host on any provider by host name 'example.com'
2015-11-24 12:37:01,367 ERROR [org.ovirt.engine.core.bll.host.provider.foreman.SystemProviderFinder] (ajp-/127.0.0.1:8702-5) [] Failed to find host on any provider by host name 'example.com'
2015-11-24 13:22:34,865 ERROR [org.ovirt.engine.core.bll.host.provider.foreman.SystemProviderFinder] (ajp-/127.0.0.1:8702-9) [] Failed to find host on any provider by host name 'example.com'
2015-11-24 13:22:35,723 ERROR [org.ovirt.engine.core.bll.host.provider.foreman.SystemProviderFinder] (ajp-/127.0.0.1:8702-6) [] Failed to find host on any provider by host name 'example.com'
Comment 1 Moti Asayag 2015-11-25 00:17:40 EST

*** This bug has been marked as a duplicate of bug 1260499 ***

Note You need to log in before you can comment on or make changes to this bug.