Bug 1284995 - Lenovo ThinkPad OneLink Pro Dock Audio jack does not output audio
Lenovo ThinkPad OneLink Pro Dock Audio jack does not output audio
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pulseaudio (Show other bugs)
7.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Wim Taymans
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 10:57 EST by David Egts
Modified: 2016-02-16 05:33 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 05:33:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Egts 2015-11-24 10:57:07 EST
Description of problem:

After upgrading my Lenovo X1 Carbon 2015 to RHEL 7.2, the Lenovo ThinkPad OneLink Pro Dock Audio jack no longer outputs audio.

The built in speakers and headphone jack work.  Switching the audio output to Lenovo ThinkPad OneLink Pro Dock Audio yields no audio output.  This used to work fine in RHEL 7.1.

Version-Release number of selected component (if applicable):

pulseaudio-6.0-7.el7.x86_64

How reproducible: 100%

Steps to Reproduce:
1. Play audio using "Speakers - Built-in Audio" as output.  Works fine.
2. Switch output to "Headphones - Built-in Audio" as output.  Works fine.
3. Switch output to "Digital Output (S/PDIF) - ThinPad Pro Dock Audio" as output.  No audio output.
4. Switch output to "Analog Output - ThinPad Pro Dock Audio" as output.  No audio output.  This used to work fine in RHEL 7.1.

Actual results:

Lenovo ThinkPad OneLink Pro Dock Audio jack does not output audio

Expected results:

Lenovo ThinkPad OneLink Pro Dock Audio jack outputs audio

Additional info:

Seems like there are related Fedora bugs, but I'm not sure if it's the same problem.
Comment 1 David Egts 2016-01-25 10:49:30 EST
Since RHEL 7.2 GA and present date, it seems like this problem went away.  Not sure if async errata fixed it or the problem was just me.

Feel free to close this.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.