Bug 1285048 - SELinux is preventing abrt-hook-ccpp from 'create' accesses on the file core.10097.
SELinux is preventing abrt-hook-ccpp from 'create' accesses on the file core....
Status: CLOSED DUPLICATE of bug 1285047
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2015-11-24 13:11 EST by Harshal
Modified: 2016-01-21 10:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-01-21 10:02:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Harshal 2015-11-24 13:11:21 EST
Description of problem:
SELinux is preventing abrt-hook-ccpp from 'create' accesses on the file core.10097.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that abrt-hook-ccpp should be allowed create access on the core.10097 file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
allow this access for now by executing:
# grep abrt-hook-ccpp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_dump_oops_t:s0
Target Context                unconfined_u:object_r:admin_home_t:s0
Target Objects                core.10097 [ file ]
Source                        abrt-hook-ccpp
Source Path                   abrt-hook-ccpp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-128.18.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.2.5-201.fc22.x86_64 #1 SMP Wed
                              Oct 28 20:00:23 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-11-23 22:35:53 IST
Last Seen                     2015-11-23 22:35:53 IST
Local ID                      994e2a08-8300-4098-bb17-7143e7ff9896

Raw Audit Messages
type=AVC msg=audit(1448298353.775:315): avc:  denied  { create } for  pid=10098 comm="abrt-hook-ccpp" name="core.10097" scontext=system_u:system_r:abrt_dump_oops_t:s0 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file permissive=1

Hash: abrt-hook-ccpp,abrt_dump_oops_t,admin_home_t,file,create

Version-Release number of selected component:

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.5-201.fc22.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2016-01-21 10:02:15 EST

*** This bug has been marked as a duplicate of bug 1285047 ***

Note You need to log in before you can comment on or make changes to this bug.