Bug 128509 - rpm _solve_name_fmt macro in /etc/rpm/macros.solve is useless
Summary: rpm _solve_name_fmt macro in /etc/rpm/macros.solve is useless
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpmdb-redhat   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Dennis Gregorovic
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 156320 169848
TreeView+ depends on / blocked
 
Reported: 2004-07-23 19:59 UTC by David Lehman
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: RHEA-2005-784
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 14:47:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to /etc/rpm/macros.solve to fix _solve_name_fmt definition (404 bytes, patch)
2004-07-23 20:01 UTC, David Lehman
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2005:784 normal SHIPPED_LIVE rpmdb-redhat enhancement update 2005-09-28 04:00:00 UTC

Description David Lehman 2004-07-23 19:59:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
/etc/rpm/macros.solve contains definitions of _solve_pkgsdir and
_solve_name_fmt. The problem is that the definition of of
_solve_name_fmt should probably have %_solve_pkgsdir prepended so
people will see that _solve_name_fmt needs the full path to the solve dir.

As it is, people will think rpm actually evaluates both macros when
looking for solution packages. Since rpm in fact only looks at
_solve_name_fmt, it would be preferable for the include solution
macros to define a working/useful _solve_name_fmt macro.



Version-Release number of selected component (if applicable):
rpm-4.2.2-0.14

How reproducible:
Always

Steps to Reproduce:
1. Set up a package repository
2. try using it to solve transaction deps by running rpm -i --aid
--define '_solve_pkgsdir /path/to/pkgrepo/' foo.rpm (from somewhere
other than in the package repo) 
3. 

Actual Results:  rpm was unable to locate the solution package repo
and the transaction failed because of unresolved deps

Expected Results:  rpm finds needed package in package repo and solves
transaction deps, installing foo.rpm successfully

Additional info:

Comment 1 David Lehman 2004-07-23 20:01:09 UTC
Created attachment 102184 [details]
Patch to /etc/rpm/macros.solve to fix _solve_name_fmt definition

Comment 2 Jeff Johnson 2004-07-26 13:06:38 UTC
/etc/rpm/macros.solve is owned by rpmdb-redhat, not rpm.

Hmmm, no component for rpmdb-redhat, so "distribution" ...

Comment 4 Dennis Gregorovic 2005-04-10 22:38:51 UTC
Fix checked in.  Need to verify in next tree.

Comment 7 Jay Turner 2005-09-27 15:23:08 UTC
This should have gotten acks.

Comment 8 Red Hat Bugzilla 2005-09-28 14:47:53 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2005-784.html



Note You need to log in before you can comment on or make changes to this bug.