Bug 1285270 - [RFE] Running VM should be based on cirros / Fedora Cloud image
[RFE] Running VM should be based on cirros / Fedora Cloud image
Status: CLOSED DEFERRED
Product: ovirt-system-tests
Classification: Community
Component: RFEs (Show other bugs)
0.4
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: David Caro
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 05:30 EST by Yaniv Kaul
Modified: 2016-06-26 19:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 14:13:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2015-11-25 05:30:04 EST
Description of problem:
CirrOS (https://launchpad.net/cirros) provides all the bits we need to launch a VM with Cloud-Init support (which we can actually login to as well).

We may need to look at guest agent support for it, though.

It is also VERY small, making it consumable, we can put it on Glance, the export domain, etc.
Comment 1 David Caro 2015-11-25 05:48:41 EST
there's already a cirros image in the git repo (7Mb) used for the lago functional tests, but yes, the guest agent does not work properly there so it's only used for the basic functional ones (start/stop/shell and a couple more).

You want to use it as base image for the second level vms? (lago starts the vdsm hosts, and inside those, the second level vms to test the vm creation and migration in ovirt)
Comment 2 Yaniv Kaul 2015-11-25 05:55:05 EST
(In reply to David Caro from comment #1)
> You want to use it as base image for the second level vms? (lago starts the
> vdsm hosts, and inside those, the second level vms to test the vm creation
> and migration in ovirt)

Right - that was the idea behind it. Looks like, as there's no packages manager even, it'd be quite a challenge not only to port but also to install the guest agent there. I guess the better solution is Fedora's cloud image (https://getfedora.org/cloud/download/) - quite bigger, but completely operational for our needs (and fully supported upstream).

I therefore rephrased the request - we should have both, use cirros for whatever doesn't involve any guest work, and Fedora for the rest. Or we can settle on a single one - Fedora cloud image?
Comment 3 David Caro 2015-11-25 05:59:13 EST
That's exactly what we are doing for the lago functional tests (the ones that run when you change lago code). We use the cirros for basic functional (run on each patch, is quite fast) and fedora cloud for the full functional tests.

We can do something similar for the ovirt-system-tests yes
Comment 4 David Caro 2016-01-27 14:13:51 EST
Moved to https://github.com/lago-project/lago/issues/49

Note You need to log in before you can comment on or make changes to this bug.