Bug 1285275 - Selinux does not allow to start smbd
Selinux does not allow to start smbd
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 05:35 EST by Kazimieras Vaina
Modified: 2016-01-21 10:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-21 10:17:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log.txt (8.79 KB, text/plain)
2015-11-25 05:35 EST, Kazimieras Vaina
no flags Details

  None (edit)
Description Kazimieras Vaina 2015-11-25 05:35:12 EST
Created attachment 1098696 [details]
log.txt

systemctl start smb.service fails

Job for smb.service failed because the control process exited with error code. See "systemctl status smb.service" and "journalctl -xe" for details.

Output of journalctl -xe command is attached to the bug report.

Package versions:
selinux-policy-3.13.1-154
selinux-policy-targeted-3.13.1-154
samba-4.3.1-3
Comment 1 Milos Malik 2015-11-25 07:37:02 EST
It seems that several directories under /var are mislabeled. Following command shows you which ones:

# restorecon -Rvn /var

Following command should fix them:

# restorecon -Rv /var
Comment 2 Kazimieras Vaina 2015-11-25 07:52:31 EST
Indeed, output of restorecon -Rvn /var showed that may files from /var/lib/samba were mislabeled.

Running another command did fix the problem. Thank you.

I suppose you may close this report as NOTABUG :)
Comment 3 Miroslav Grepl 2016-01-21 10:17:07 EST
Thank you.

Note You need to log in before you can comment on or make changes to this bug.