Bug 12853 - Funnies w/ installer's rpm on RH6.x system
Funnies w/ installer's rpm on RH6.x system
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On: 12027
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-23 09:22 EDT by Pekka Savola
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-14 14:11:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2000-06-23 09:22:25 EDT
( I'm not sure where to file this, but here it goes under installer with
Cc: to jbj)

Funnies happen if you copy RedHat/instimage/usr/bin/rpm over to a RH6x 
system to be able to query packages etc.:
---
[root@linftp bin]# ./rpm -qi kernel
error: cannot open file kernel: No such file or directory
---
'rpm -q --info kernel' works fine, as does 'rpm -q kernel'.

There may be other issues like this, I didn't check all the possibilities.

Please note that copying /bin/rpm from a fresh beta2 install works
properly.  This looks interesting, because both seem to be static binaries,
but the /bin/rpm is 886k while the instimage ver is 1343k..   

Instimage version works fine on beta2 install.
Comment 1 Bill Nottingham 2000-06-23 17:35:13 EDT
That isn't going to work right; even though it's statically linked, it's
against a different libc; also, it's a different version of RPM, and so it
expects a different configuration; the querying stuff in RPM is actually
done with separate executables by popt magic.
Comment 2 Pekka Savola 2000-06-23 17:50:14 EDT
Ok, I don't know the internals of RPM, but the main issue (apart from general
wondering still remains).

That is, 'rpm -qi' (rpm from instimage) won't work on RH62, even though 'rpm -q 
--info' does.  The same functionatily there, so fixing it probably shouldn't be 
a big problem.

This is almost certainly tied closely to #12027 (similar, but slightly different 
stuff w/ beta1).
Comment 3 Michael Fulbright 2000-07-06 21:52:59 EDT
This is more of an rpm issue than installer issue.
Comment 4 Pekka Savola 2000-07-12 09:58:37 EDT
Lowered severity.

Similar things happen with beta3 too; for example, rpm --info is not recognized.

Comment 5 Jeff Johnson 2000-07-20 14:04:05 EDT
This isn't really an rpm bug, but rather an issue with the environment in which
rpm runs.
Even though rpm is statically linked, several helper functions and a popt
configuration
to re-exec the helper functions are now needed to do anything but 
install/upgrade/erase
(and some of the options used  by install/upgrade are also now implemented with
popt
magic).

If this is still in issue, please change the component to anaconda, as the fix
will involve
setting up suffcient environment  in the installer to execute rpm.
Comment 6 Pekka Savola 2000-07-22 14:19:16 EDT
Changed component to anaconda as suggested.

The behaviour still persists with beta4.

Note You need to log in before you can comment on or make changes to this bug.