Bug 1285435 - [Beaker 21.2] System is reserved yet job progress bar shows 100%
[Beaker 21.2] System is reserved yet job progress bar shows 100%
Status: CLOSED WONTFIX
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
develop
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 10:15 EST by PaulB
Modified: 2015-12-01 20:11 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-01 20:11:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description PaulB 2015-11-25 10:15:15 EST
Description of problem:
When a system is reserved, the progress bar shows 100%.
I find this misleading, as the progress bar should represent
the "true status" of the job. Until the job status is Completed/Aborted/Cancelled the progress bar should _not_ show 100%. The use of the reservesys task or element is part of the job. If a system is reserved, the job is not truly over until the system is returned.

In previous version of beaker the progress bar did NOT
show 100%. I found this to be much more useful and obvious.

Version-Release number of selected component (if applicable):
Beaker 21.2 

Expected results:
Until the status is Completed/Aborted/Cancelled
the progress bar should _not_ show 100%.

Additional info:
I often search for systems in order to retest/reproduce kernel testing issues.
I get to the systems page and click on the currently running recipe.
-or-
I am searching by jobs by a particular user (aka who is squatting on host)

Though the job status says "Reserved" the job progress is all green at 100% :/
(All the green lights and 100% progress bar to me signify the job is done)
Comment 1 Roman Joost 2015-11-26 18:23:14 EST
Dear Paul,

thank you for your report. I think you're seeing this because a while back we've added support for taskless reservation of Beaker systems (https://beaker-project.org/docs/whats-new/release-0.17.html#harness-independent-system-reservation). The progress bar therefore reflects the status of all tasks. The reservation is separate to the tasks  by design and therefore shows 100% completed.

The reservation will happen regardless of the state the system is in and additionally the reservation does not affect the results of the tasks (see Bug 639938).

For searching for users who are squatting on hosts, we're working on implementing Bug 623562 which will provide you with the ability to find them quickly.

So long story short, I'd like to close this item with your permission since the way Beaker shows the progress bar now is intentional.

Kind Regards!
Comment 2 PaulB 2015-11-30 08:26:44 EST
(In reply to Roman Joost from comment #1)
> Dear Paul,
> 
> thank you for your report. I think you're seeing this because a while back
> we've added support for taskless reservation of Beaker systems
> (https://beaker-project.org/docs/whats-new/release-0.17.html#harness-
> independent-system-reservation). The progress bar therefore reflects the
> status of all tasks. The reservation is separate to the tasks  by design and
> therefore shows 100% completed.
> 
> The reservation will happen regardless of the state the system is in and
> additionally the reservation does not affect the results of the tasks (see
> Bug 639938).
> 
> For searching for users who are squatting on hosts, we're working on
> implementing Bug 623562 which will provide you with the ability to find them
> quickly.
> 
> So long story short, I'd like to close this item with your permission since
> the way Beaker shows the progress bar now is intentional.
> 
> Kind Regards!

Roman,
I detailed my opinion (2 cents) in the opening comment.
In short:
"The use of the reservesys task or element is part of the job. If a system is reserved, the job is not truly over until the system is returned."

I guess I find the current/intentional use of the progress bar misleading.
I found the GUI to be much more useful when it reflected the state of the reservesys. If no one else is of the same opinion, feel free to close.

Best,
-pbunyan
Comment 3 Roman Joost 2015-12-01 20:11:09 EST
Dear Paul,

I'm closing this bug as WONTFIX at this point in time. However if we get more people finding it misleading I'm happy to re-open the report.

Cheers

Note You need to log in before you can comment on or make changes to this bug.