Bug 1285458 - ssh backend for duplicity fails with 'UnsupportedBackendScheme: scheme not supported in url'
ssh backend for duplicity fails with 'UnsupportedBackendScheme: scheme not su...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: duplicity (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 11:11 EST by Juan Orti
Modified: 2016-12-20 11:17 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-20 11:17:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juan Orti 2015-11-25 11:11:43 EST
Description of problem:
My backup job fails in F23, it used to work fine in F22. I run duplicity with duply and it uses the ssh backend.

Version-Release number of selected component (if applicable):
duplicity-0.7.05-1.fc23.x86_64


How reproducible:
Always

Steps to Reproduce:
1. duply backup remote

Actual results:
Detalle de error del usuario: Traceback (most recent call last):
  File "/usr/bin/duplicity", line 1525, in <module>
    with_tempdir(main)
  File "/usr/bin/duplicity", line 1519, in with_tempdir
    fn()
  File "/usr/bin/duplicity", line 1357, in main
    action = commandline.ProcessCommandLine(sys.argv[1:])
  File "/usr/lib64/python2.7/site-packages/duplicity/commandline.py", line 1103, in ProcessCommandLine
    backup, local_pathname = set_backend(args[0], args[1])
  File "/usr/lib64/python2.7/site-packages/duplicity/commandline.py", line 994, in set_backend
    globals.backend = backend.get_backend(bend)
  File "/usr/lib64/python2.7/site-packages/duplicity/backend.py", line 223, in get_backend
    obj = get_backend_object(url_string)
  File "/usr/lib64/python2.7/site-packages/duplicity/backend.py", line 204, in get_backend_object
    raise UnsupportedBackendScheme(url_string)
UnsupportedBackendScheme: scheme not supported in url: ssh://user@host:9443//mnt/backups/duplicity

Expected results:
No errors

Additional info:
I use the port 9443 for ssh
Comment 1 Kai Engert (:kaie) 2016-07-04 15:20:33 EDT
I just found this bug, after I ran into the same issue.

I've learned that the duplicity backend has stopped supporting the "ssh" backend.

In my existing configuration, it worked after I replaced the ssh:// part of the URI with sftp://

Does that work for you, too?
Comment 2 Juan Orti 2016-07-05 02:50:09 EDT
Yes, using sftp:// works. I'm currently using rsync:// which also uses ssh.

Thank you.
Comment 3 Fedora End Of Life 2016-11-24 08:44:15 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 4 Fedora End Of Life 2016-12-20 11:17:21 EST
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.