Bug 1285487 - Update gPXE / kickstart provisioning procedure
Update gPXE / kickstart provisioning procedure
Status: CLOSED NEXTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Provisioning Guide (Show other bugs)
Unspecified
Unspecified Unspecified
medium Severity medium (vote)
: Beta
: 6.X
Assigned To: Melanie Corr
Russell Dickenson
:
: 1308896 (view as bug list)
Depends On:
Blocks: 1215144
  Show dependency treegraph
 
Reported: 2015-11-25 12:54 EST by Deon Ballard
Modified: 2017-11-10 03:25 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-10 03:25:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deon Ballard 2015-11-25 12:54:39 EST
Document URL: 
 https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/User_Guide/sect-Red_Hat_Satellite-User_Guide-Configuring_the_Provisioning_Environment-Configuring_Provisioning_Settings.html#sect-Red_Hat_Satellite-User_Guide-Configuring_Provisioning_Settings-Configuring_gPXE_to_Reduce_Provisioning_Times 


Describe the issue: 

Async1 added a procedure on how to configure (faster) gPXE-based provisioning for kickstart. The procedure there contained a couple of workarounds, and there is a fix in for 6.2 on the engineering side. So, the procedure should be updated. 

Engineering patch: https://github.com/theforeman/community-templates/pull/221


Suggestions for improvement: 

From lzap:
This page explains everything (it's been updated):

http://projects.theforeman.org/projects/foreman/wiki/Fetch_boot_files_via_http_instead_of_TFTP

* Except instead downloading the file from internet, use the file that
ships with Satellite, /usr/share/ipxe/ipxe.lkrn. Note that iPXE is just a more recent (renamed) version of the gPXE project. 

* When working on the documentation, make sure to not that not all
hardware is compatible with iPXE/gPXE! It's quite subset of PXE-capable
hardware.

http://ipxe.org/appnote/hardware_drivers

* A new profile will *not* be shipped in Satellite 6.2, so the copy operation is still necessary to create an iPXE profiel. BTW symlink will NOT work because of chroot and SELinux; make a copy and fix labels in your documentation.


Additional information: 
Related bug: https://bugzilla.redhat.com/show_bug.cgi?id=1215144
Comment 2 Andrew Dahms 2016-11-15 07:08:17 EST
Moving to NEW and the default assignee to be triaged as the schedule allows.
Comment 3 Andrew Dahms 2017-09-21 20:33:23 EDT
Hi Lukas,

I am just reviewing some of the older bugs in our queue to see what we can do to make some progress on them.

After looking over the description, it looks like what we need to do here is adapt the information you linked to into our documentation to provide some content on each of the scenarios.

Just to confirm - of A, B, and C, are there any that would not be supported with Satellite 6, or can we document them all?

Kind regards,

Andrew
Comment 4 Andrew Dahms 2017-09-21 20:42:43 EDT
Assigning to Melanie for review.

Melanie - the "Configuring gPXE to Reduce Provisioning Times" section is now located in the Provisioning Guide.

It looks like we need to do a few things to update this section, as follows -

* Add the steps of the scenario described to the documentation

* Add the list of requirements to the documentation

* Add three sub-sections to cover each of the scenarios A, B, and C pending
  a response to the above question in comment #3.

* Adapt the text so that it assumes the environment is Red Hat, and to fit
  the style of our documentation.

  For example, scenario A would be a two-step procedure along the lines of
  the following -

  Copy the iPXE firmware to the TFTP root directory:
    # cp /usr/share/ipxe/ipxe.lkrn /var/lib/tftpboot/
  Correct the file context:
    # restorecon -RvF /var/lib/tftpboot/

  And a 'Note' admonition box that tells users not to use symlinks. In our
  documentation, we always assume that SELinux is running as well, so we
  tend to just tell users to perform steps rather than leaving it as an
  option.

Kind regards,

Andrew
Comment 5 Andrew Dahms 2017-09-26 21:10:35 EDT
*** Bug 1308896 has been marked as a duplicate of this bug. ***
Comment 16 Steve Bream 2017-11-07 05:42:14 EST
Hi Melanie,

It's not illegal per se to mention it, but I do agree with Russell that we should remove it. By including it in the documentation we put some burden, official or not, on the support team to try to support it.

So let's go ahead and pull it. The information is available from another site and not hard to find.

Thanks,
Steve
Comment 21 Melanie Corr 2017-11-10 03:25:18 EST
I can confirm this content is now merged.

Note You need to log in before you can comment on or make changes to this bug.