Bug 1285596 - rhel-osp-director: 7.2 - HA overcloud deployment doesn't return the prompt, although reported in heat stack-list as completed.
rhel-osp-director: 7.2 - HA overcloud deployment doesn't return the prompt, ...
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: y3
: 7.0 (Kilo)
Assigned To: chris alfonso
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 20:54 EST by Alexander Chuzhoy
Modified: 2016-04-18 02:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-26 13:42:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs from a controller with the failed heat. (5.06 MB, application/x-gzip)
2015-11-25 20:56 EST, Alexander Chuzhoy
no flags Details

  None (edit)
Description Alexander Chuzhoy 2015-11-25 20:54:24 EST
rhel-osp-director: 7.2 - HA overcloud deployment  doesn't return the prompt, although reported in heat stack-list as completed.


Environment:
openstack-heat-engine-2015.1.2-2.el7ost.noarch
instack-undercloud-2.1.2-34.el7ost.noarch
openstack-heat-api-2015.1.2-2.el7ost.noarch
openstack-heat-common-2015.1.2-2.el7ost.noarch
openstack-tripleo-heat-templates-0.8.6-85.el7ost.noarch
openstack-heat-templates-0-0.7.20150605git.el7ost.noarch


Steps to reproduce:
Deploy HA overcloud  with network isolation, 2 computes and  3 ceph nodes.

Result:
The deployment doesn't end, although the timeout is set to 90 minutes.
running "heat stack-list" shows:
+--------------------------------------+------------+-----------------+----------------------+
| id                                   | stack_name | stack_status    | creation_time        |
+--------------------------------------+------------+-----------------+----------------------+
| e4234dce-744d-45c2-8a11-6a06b4ed7d89 | overcloud  | CREATE_COMPLETE | 2015-11-25T23:22:03Z |
+--------------------------------------+------------+-----------------+----------------------+

Running commands against the overcloud results in:
No handlers could be found for logger "keystoneclient.auth.identity.generic.base"
ERROR (ConnectionRefused): Unable to establish connection to http://10.19.184.180:5000/v2.0/tokens


openstack-heat-api.service was failed on one controller out of 3.


Expected result:
The deployment should complete successfully.
Comment 1 Alexander Chuzhoy 2015-11-25 20:56 EST
Created attachment 1099072 [details]
logs from a controller with the failed heat.
Comment 2 Alexander Chuzhoy 2015-11-25 20:57:02 EST
The deployment command was:
openstack overcloud deploy --templates --control-scale 3 --compute-scale 2  --ceph-storage-scale 3 --ntp-server 10.5.26.10  --timeout 90  -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml   -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml  -e /home/stack/network-environment.yaml
Comment 3 Alexander Chuzhoy 2015-11-25 21:55:04 EST
Here's a result from another deployment on the same setup, although without ceph nodes:
openstack overcloud deploy --templates --control-scale 3 --compute-scale 2 --ntp-server 10.5.26.10  --timeout 90  -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml  -e /home/stack/network-environment.yaml
Deploying templates in the directory /usr/share/openstack-tripleo-heat-templates
/home/stack/.ssh/known_hosts updated.
Original contents retained as /home/stack/.ssh/known_hosts.old
PKI initialization in init-keystone is deprecated and will be removed.



ssh: connect to host 10.19.94.10 port 22: Connection timed out
ERROR: openstack Command '['ssh', '-oStrictHostKeyChecking=no', '-t', '-l', 'heat-admin', u'10.19.94.10', 'sudo', 'keystone-manage', 'pki_setup', '--keystone-user', "$(getent passwd | grep '^keystone' | cut -d: -f1)", '--keystone-group', "$(getent group | grep '^keystone' | cut -d: -f1)"]' returned non-zero exit status 255
[stack@undercloud ~]$ openstack overcloud deploy --templates --control-scale 3 --compute-scale 2 --ntp-server 10.5.26.10  --timeout 90  -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml  -e /home/stack/network-environment.yaml
Deploying templates in the directory /usr/share/openstack-tripleo-heat-templates


Note: InternalApiNetCidr: 10.19.94.0/24
The undercloud can't connect there.
Comment 4 Alexander Chuzhoy 2015-11-26 13:42:15 EST
It was due to an IP collision with another setup.
Able to deploy after the issue was fixed.

Note You need to log in before you can comment on or make changes to this bug.