Bug 1285696 - New vNIC/edit - The vNIC type for VMs is 'pci-passthourh' by default for all profiles, regular and passthrough ones
New vNIC/edit - The vNIC type for VMs is 'pci-passthourh' by default for all ...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
3.6.1
x86_64 Linux
high Severity high (vote)
: ovirt-3.6.1
: 3.6.1.2
Assigned To: Martin Mucha
Michael Burman
network
: Regression
Depends On:
Blocks: 1271912
  Show dependency treegraph
 
Reported: 2015-11-26 04:51 EST by Michael Burman
Modified: 2016-02-10 14:16 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 07:22:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
danken: ovirt‑3.6.z?
rule-engine: blocker?
mburman: planning_ack?
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
screenshot (51.08 KB, image/png)
2015-11-26 04:51 EST, Michael Burman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 49317 master MERGED webadmin: set VirtIO type if profile is not passthrough enabled. Never
oVirt gerrit 49392 ovirt-engine-3.6 MERGED webadmin: set VirtIO type if profile is not passthrough enabled. Never
oVirt gerrit 49453 ovirt-engine-3.6.1 MERGED webadmin: set VirtIO type if profile is not passthrough enabled. Never

  None (edit)
Description Michael Burman 2015-11-26 04:51:38 EST
Created attachment 1099202 [details]
screenshot

Description of problem:
New vNIC/edit - The vNIC type for VMs is 'pci-passthourh' by default for all profiles, regular and passthrough ones.

It's a regression and i think it caused by the fix for this BZ 1271912.


Version-Release number of selected component (if applicable):
3.6.1-0.2.el6

How reproducible:
100

Steps to Reproduce:
1. Add new vNIC to VM or edit exist one

Actual results:
The vNIC type is 'pci-passthrough' by default for all profiles.

Expected results:
VirtIO type for regular profiles.
pci-passthrough type for passthrough profiles.

Additional info:
See also BZ 1271912
Comment 1 Michael Burman 2015-11-26 09:51:27 EST
After further investigation, this bug happens and triggered when we have a 'passthrough' vNIC profile/s in the setup. ('passthrough' checkbox is checked).
If non of our vNIC profiles has the 'passthrough' checkbox checked, the default type for VMs vNICs is VirtIO.
Comment 2 Red Hat Bugzilla Rules Engine 2015-11-27 00:40:40 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 3 Red Hat Bugzilla Rules Engine 2015-11-27 04:24:24 EST
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 7 Sandro Bonazzola 2015-12-03 02:39:15 EST
3.6.1.1 has been released, if this bug is not fixed in 3.6.1.1 please change release target to 3.6.1.2 and move back to modified.
Comment 8 Michael Burman 2015-12-10 03:55:20 EST
Verified on - 3.6.1.2-0.1.el6
Comment 9 Sandro Bonazzola 2015-12-16 07:22:52 EST
According to verification status and target milestone this issue should be fixed in oVirt 3.6.1. Closing current release.

Note You need to log in before you can comment on or make changes to this bug.