Bug 1285722 - pcsd runs as initrc_t (is not confined by SELinux)
pcsd runs as initrc_t (is not confined by SELinux)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 05:39 EST by Milos Malik
Modified: 2016-06-02 02:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1341945 (view as bug list)
Environment:
Last Closed: 2015-11-30 06:59:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2015-11-26 05:39:49 EST
Description of problem:
 * one of many cluster services is not confined
 * the pcsd process runs as initrc_t on RHEL-6
 * the pcsd process runs as cluster_t on RHEL-7

Version-Release number of selected component (if applicable):
pcs-0.9.139-9.el6.x86_64
selinux-policy-3.7.19-283.el6.noarch
selinux-policy-doc-3.7.19-283.el6.noarch
selinux-policy-minimum-3.7.19-283.el6.noarch
selinux-policy-mls-3.7.19-283.el6.noarch
selinux-policy-targeted-3.7.19-283.el6.noarch

How reproducible:
always

Steps to Reproduce:
# service pcsd status
pcsd is stopped
# service pcsd start
Starting pcsd:                                             [  OK  ]
# service pcsd status
pcsd (pid  4395) is running...
# ps -efZ | grep pcsd
unconfined_u:system_r:initrc_t:s0 root    4395     1  6 11:33 pts/0    00:00:00 /usr/bin/ruby -I/usr/lib/pcsd /usr/lib/pcsd/ssl.rb
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 root 4427 4321  0 11:33 pts/0 00:00:00 grep pcsd
#

Actual results:
 * the service is not confined

Expected results:
 * the service is confined
Comment 1 Miroslav Grepl 2015-11-30 06:59:10 EST
If it does not cause any issues we can leave it with initrc_t for RHEL-6. Closing the bus as WONTFIX in RHEL-6 because we have fixes in RHEL-7.

Note You need to log in before you can comment on or make changes to this bug.