Bug 1285784 - [RFE] write virt-builder plugin to handle templates for lago
[RFE] write virt-builder plugin to handle templates for lago
Status: CLOSED NOTABUG
Product: ovirt-system-tests
Classification: Community
Component: Core (Show other bugs)
0.4
Unspecified Unspecified
high Severity unspecified
: milestone3
: 0.5
Assigned To: David Caro
Eyal Edri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 08:11 EST by Eyal Edri
Modified: 2016-06-26 19:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 14:33:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eyal Edri 2015-11-26 08:11:49 EST
Description of problem:
Today we use custom templates created by unknown logic, based on several operating systems and configurations.

the flow to store,download and manage those templates is using custom code which is internal to lago and not using standard or known open source projects that already solved this problem like vagrant or virt-builder.

the purpose of this bug is to add a formal way of managing templates built as a plugin that will use virt-builder.
we choose virt-builder as the 1st plugin because its simplicity and the fact we can manage the templates on our own html server.

we might want to add in the future more plugins like glance or packager.io support.

the following might be opened as seperate bugs to handle each issue:

 - The plugin should support using images from libguestfs
 - The plugin should check if cloudinit is enabled and have ability to disable 
   it in the image, for performance purposes.
 - optional - check if artifactory can store images instead of http server, as 
     separate plugin?
 - check if its possible to provide support for legacy templates and new plugin at the same time, if not - we need to provide working version with legacy way and announce on new version without backward compatibility.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Eyal Edri 2015-12-13 01:37:33 EST
following last week bug scrub,
will this be postponed for the next version? do we have other bugs we're re-targeting for 0.5?
Comment 2 David Caro 2016-01-26 04:18:10 EST
I'm not sure this is possible if we want to use layered templates, virt-builder will never support them on the client side (the one that downloads them locally)
Comment 3 David Caro 2016-01-27 14:33:34 EST
Closing as notabug until we decide

Note You need to log in before you can comment on or make changes to this bug.