Bug 1285806 - synfig.spec does not correctly pass CPPFLAGS to %configure
synfig.spec does not correctly pass CPPFLAGS to %configure
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: synfig (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 09:05 EST by Jonathan Wakely
Modified: 2017-03-15 11:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-15 11:08:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Wakely 2015-11-26 09:05:46 EST
The synfig spec file says:

%configure --disable-static --with-imagemagick --with-magickpp \
        --without-libavcodec
        CPPFLAGS='-DMagickLib=MagickCore -I/usr/include/ImageMagick'

The CPPFLAGS variable will not be passed to configure, because there is a missing backslash on the line before it, and CPPFLAGS is not one of the variables exported by %configure

Presumably the line doesn't do anything and so could be removed, but someone who knows this package should determine that and decide what to do.
Comment 1 Jan Kurik 2016-02-24 09:02:32 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Note You need to log in before you can comment on or make changes to this bug.