Bug 1285823 - sudo gnome-software keeps running after closing the application window
sudo gnome-software keeps running after closing the application window
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-software (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 09:51 EST by Jiri Prajzner
Modified: 2015-12-01 19:44 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-30 05:22:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Prajzner 2015-11-26 09:51:31 EST
Description of problem:
The GNOME Software application launched via sudo with --verbose option from terminal keeps running even after the application window is closed. Screenshot attached.

Version-Release number of selected component (if applicable):
3.18.3

How reproducible:
Every time

Steps to Reproduce:
1. sudo gnome-software --verbose
2. close the application window
3.

Actual results:
The application keeps sending the verbose output into terminal

Expected results:
The application exits properly.

Additional info:
Comment 1 Kalev Lember 2015-11-26 11:34:41 EST
In a normal operation, you would never have to run gnome-software as root. We have privilege separation where the UI code can run as the regular user and packagekitd runs with elevated privileges.

Also, normally gnome-software is started together with the user session when logging in and stays resident in the memory all the time. That's also why it never quits after closing the window and just keeps running :)
Comment 2 Jiri Prajzner 2015-11-27 08:25:00 EST
I didn't expect it to just hide the window on close, I expected it to return the prompt and continue whatever it is doing invisibly in the background, perhaps. I'm not an expert though.
Comment 3 Richard Hughes 2015-11-30 05:22:43 EST
Agreed, this is the intended thing to happen. It's not normal for session programs like this to daemonize.
Comment 4 Rafal Luzynski 2015-12-01 19:44:37 EST
I'd disagree with you guys. AFAIU the application should normally keep running forever when launched with --gapplication-service argument but it keeps running forever even without this option. I find this a minor bug because normal users always run it with --gapplication-service and hackers are already used to terminating the process with Ctrl+C or simply kill(1). The issue has nothing to do with running as root. So my steps to reproduce are:

1. killall gnome-software # to make sure we start the first instance
2. gnome-software
3. close the application window
4. (nothing happens, the window is closed but the application keeps running)

Expected results:
The application exits properly unless launched with --gapplication-service argument.

Note You need to log in before you can comment on or make changes to this bug.