Bug 1285828 - Running undercloud installation for a second time fails
Running undercloud installation for a second time fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: ---
: 10.0 (Newton)
Assigned To: Ben Nemec
Marius Cornea
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 10:16 EST by Marius Cornea
Modified: 2016-10-05 15:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-05 15:53:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Cornea 2015-11-26 10:16:26 EST
Description of problem:
Running openstack undercloud install for a second time fails. It looks that it's trying to delete existing neutron subnets but it fails since they contain ports assigned to the overcloud nodes. 

Version-Release number of selected component (if applicable):
instack-0.0.7-2.el7ost.noarch
instack-undercloud-2.1.2-34.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install undercloud
2. Deploy overcloud with net iso
3. Reinstall undercloud

Actual results:
Installation fails:
Unable to complete operation on subnet 047059a4-0b06-47c6-9a0f-5b17b36bef23. One or more ports have an IP allocation from this subnet.

Expected results:
Installation succeeds.

Additional info:
+ neutron subnet-delete 047059a4-0b06-47c6-9a0f-5b17b36bef23 4cad5e42-c36a-4412-8083-c7ebd8568bc0 a95d3ebd-0278-4243-8dbe-854c35ba8236 29368356-de6d-4943-98b6-fd05583d6488 d6903b6e-8378-4293-ae5d-4a17c0cc7684 e6272f21-1600-4d46-afb8-b5f4678a5935
Unable to complete operation on subnet 047059a4-0b06-47c6-9a0f-5b17b36bef23. One or more ports have an IP allocation from this subnet.
[2015-11-26 09:14:07,658] (os-refresh-config) [ERROR] during post-configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/post-configure.d']' returned non-zero exit status 1]

[2015-11-26 09:14:07,659] (os-refresh-config) [ERROR] Aborting...
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 526, in install
    _run_orc(instack_env)
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 461, in _run_orc
    _run_live_command(args, instack_env, 'os-refresh-config')
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 297, in _run_live_command
    raise RuntimeError('%s failed. See log for details.', name)
RuntimeError: ('%s failed. See log for details.', 'os-refresh-config')
ERROR: openstack Command 'instack-install-undercloud' returned non-zero exit status 1
Comment 2 Mike Burns 2016-04-07 17:00:12 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 3 Jaromir Coufal 2016-10-05 15:53:44 EDT
Should be working now.

Note You need to log in before you can comment on or make changes to this bug.