Bug 1285837 - Containers: 'Unexpected error encountered' when selecting "back" arrow -> all containers
Containers: 'Unexpected error encountered' when selecting "back" arrow -> all...
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
x86_64 Linux
high Severity high
: GA
: 5.6.0
Assigned To: Dan Clarizio
Dave Johnson
: ZStream
Depends On:
Blocks: 1287856
  Show dependency treegraph
 
Reported: 2015-11-26 10:49 EST by Dafna Ron
Modified: 2016-04-12 00:17 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1287856 (view as bug list)
Environment:
Last Closed: 2016-02-25 13:04:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot of arraw (150.24 KB, image/png)
2015-11-26 10:49 EST, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2015-11-26 10:49:46 EST
Created attachment 1099334 [details]
screen shot of arraw

Description of problem:

occurs when selecting "back" arrow -> all containers

Version-Release number of selected component (if applicable):

cfme-5.5.0.12-rc2.1.el7cf.x86_64

How reproducible:

100%

Steps to Reproduce:
1. navigate to containers -> containers
2. select a container
3. select back arrow -> all containers

Actual results:

Unexpected error encountered 

Expected results:

We should go back to view all containers

Additional info:



Unexpected error encountered

Errors in Management Engine can be caused by:

① Accessing Management Engine from multiple tabs or windows of the same browser on a single machine. Close any duplicate browser sessions, then select a menu option above.
② Pressing the back button during a session.
      Close any duplicate browser sessions, then select a menu option above.
③ An internal system error.
      Please contact your administrator for assistance.


Error text:

undefined method `name' for nil:NilClass [container/x_history]
Comment 1 Erez Freiberger 2015-11-29 07:42:40 EST
I can not reproduce the bug. tested on upstream and on 5.5.0.12
Could you attach evm.log ?
Comment 2 Dafna Ron 2015-11-30 05:30:31 EST
My vm rebooted and I was unable to reproduce again.
I think it has to do with us saving the history of screens that had an error.
Since I only selected one object which had an exception, once I pressed the back button I got that screen.

Perhaps this bug needs to change to "we are saving history of exception screens"?
Comment 3 Federico Simoncelli 2015-11-30 06:10:08 EST
(In reply to Dafna Ron from comment #2)
> My vm rebooted and I was unable to reproduce again.
> I think it has to do with us saving the history of screens that had an error.
> Since I only selected one object which had an exception, once I pressed the
> back button I got that screen.
> 
> Perhaps this bug needs to change to "we are saving history of exception
> screens"?

Try to reproduce, if that's the case this is a generic bug and it should be reassigned to Dan (remove container from the whiteboard as well).
Comment 4 Federico Simoncelli 2016-02-05 08:58:29 EST
What we understood so far is that the page error generated by bug 1286247 ended up in the breadcrumbs and when selecting "back" arrow you were reaching the same page error.

We haven't been able so far to reproduce this with any other error page and bug 1286247 is fixed.

I think we should either close this or move it to CFME infrastructure to see if it's possible to avoid putting crashing pages in the breadcrumbs.

Note You need to log in before you can comment on or make changes to this bug.