This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1285843 - avahi_client_free called with NULL
avahi_client_free called with NULL
Status: CLOSED DUPLICATE of bug 1281449
Product: Fedora
Classification: Fedora
Component: geoclue2 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Zeeshan Ali
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 11:09 EST by Harald Hoyer
Modified: 2016-09-19 21:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-27 11:55:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Hoyer 2015-11-26 11:09:31 EST
# rpm -qf /usr/libexec/geoclue
geoclue2-2.4.0-1.fc24.x86_64



#4  0x00007fdd7e5d83ab in avahi_client_free (client=<optimized out>) at client.c:626
626	    assert(client);
(gdb) up
#5  0x000055a0ede021fd in gclue_nmea_source_finalize (gnmea=0x7fdd6c004f70 [GClueNMEASource]) at gclue-nmea-source.c:596
596	        avahi_client_free (priv->avahi_client);
(gdb) up
#6  0x00007fdd7d90294f in g_object_unref (_object=0x7fdd6c004f70) at gobject.c:3179
3179	          G_OBJECT_GET_CLASS (object)->finalize (object);
(gdb) up
Python Exception <class 'TypeError'> iter() returned non-iterator of type '_iterator': 
#7  0x00007fdd7d5f953d in g_list_foreach (list=<optimized out>, list@entry=0x55a0eef6f360, func=0x7fdd7d9027d0 <g_object_unref>, 
    user_data=user_data@entry=0x0) at glist.c:1005
1005	      (*func) (list->data, user_data);
(gdb) up
Python Exception <class 'TypeError'> iter() returned non-iterator of type '_iterator': 
#8  0x00007fdd7d5f955b in g_list_free_full (list=0x55a0eef6f360, free_func=<optimized out>) at glist.c:220
220	  g_list_foreach (list, (GFunc) free_func, NULL);
(gdb) up
#9  0x000055a0eddfd070 in gclue_locator_finalize (gsource=<optimized out>) at gclue-locator.c:286
286	        g_list_free_full (priv->sources, g_object_unref);
(gdb) up
#10 0x00007fdd7d90294f in g_object_unref (_object=0x55a0eef54350) at gobject.c:3179
3179	          G_OBJECT_GET_CLASS (object)->finalize (object);
Comment 1 Harald Hoyer 2015-11-26 11:10:28 EST
(gdb) up
#11 0x000055a0eddf0983 in gclue_service_manager_finalize (object=0x55a0eef51240 [GClueServiceManager]) at gclue-service-manager.c:408
408	        g_clear_object (&priv->locator);
(gdb) up
#12 0x00007fdd7d90294f in g_object_unref (_object=0x55a0eef51240) at gobject.c:3179
3179	          G_OBJECT_GET_CLASS (object)->finalize (object);
(gdb) up
#13 0x000055a0eddeee46 in main (argc=1, argv=0x7ffd2f350f78) at gclue-main.c:195
195	                g_object_unref (manager);
Comment 2 Zeeshan Ali 2015-11-27 11:55:28 EST

*** This bug has been marked as a duplicate of bug 1281449 ***

Note You need to log in before you can comment on or make changes to this bug.