Bug 128593 - RPM solaris filepath problem
Summary: RPM solaris filepath problem
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-26 21:19 UTC by Mark Hatle
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-06 14:22:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for _D_EXACT_NAMELEN(d) macro (290 bytes, patch)
2004-07-26 21:20 UTC, Mark Hatle
no flags Details | Diff

Description Mark Hatle 2004-07-26 21:19:04 UTC
Description of problem:
RPM > 4.1 contains a bug when building on solaris.

Specifically if you have a filepath/name that looks like:

/mypath/foo/foo

RPM reports a cyclical link and aborts.

Version-Release number of selected component (if applicable):
4.3.x definatly has this problem, I did not check 4.2.

Comment 1 Mark Hatle 2004-07-26 21:20:53 UTC
Created attachment 102210 [details]
Fix for _D_EXACT_NAMELEN(d) macro

The following is the proper way to detect the filename length.	The old
mechanism used the whole record length, which causes problems.

Comment 2 Jeff Johnson 2006-01-06 14:22:00 UTC
Checked in, will be in rpm-4.4.5-0.5 when built.


Note You need to log in before you can comment on or make changes to this bug.