This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1286003 - non declared dependency on python-oslo-serialization
non declared dependency on python-oslo-serialization
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-ceilometerclient (Show other bugs)
6.0 (Juno)
x86_64 Linux
high Severity high
: async
: 6.0 (Juno)
Assigned To: Mehdi ABAAKOUK
Shai Revivo
: AutoVerified, ZStream
: 1311422 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-27 03:26 EST by Matthias Runge
Modified: 2016-07-20 08:36 EDT (History)
6 users (show)

See Also:
Fixed In Version: python-ceilometerclient-1.0.14-4.el7ost.noarch
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-20 08:36:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Runge 2015-11-27 03:26:00 EST
Description of problem:
in a recent OSP-6 install:

rpm -q python-ceilometerclient
python-ceilometerclient-1.0.14-2.el7ost.noarch

rpm -q --requires python-ceilometerclient
/usr/bin/python
python(abi) = 2.7
python-argparse
python-iso8601
python-keystoneclient
python-oslo-utils
python-prettytable
python-setuptools
python-six >= 1.7.0
python-stevedore
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1


but:
/usr/lib/python2.7/site-packages/ceilometerclient/common/utils.py has:

#    under the License.

from __future__ import print_function

import sys
import textwrap
import uuid

from oslo.serialization import jsonutils
 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

from oslo.utils import encodeutils
from oslo.utils import importutils
import prettytable
Comment 2 Matthias Runge 2016-02-24 03:42:08 EST
*** Bug 1311422 has been marked as a duplicate of this bug. ***
Comment 6 errata-xmlrpc 2016-07-20 08:36:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1459

Note You need to log in before you can comment on or make changes to this bug.