Bug 128604 - rpm CPU detection on ppc G4
Summary: rpm CPU detection on ppc G4
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: rawhide
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-26 23:29 UTC by Nanar
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-27 08:14:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nanar 2004-07-26 23:29:14 UTC
Description of problem: 
 
This patch fix the ppc detection, else rpm don't find G4 cpu as 'ppc' 
but as ppcseries. This is due to the pvr return by CPU less than 
8000. 
 
It has been tested and works (since rpm 4.2 nd apply to mandrake's 
rpm). 
 
The patch: 
 
--- rpm-4.2/lib/rpmrc.c.ppc-g4  2003-01-07 11:04:01.000000000 -0500 
+++ rpm-4.2/lib/rpmrc.c 2003-01-11 03:03:51.000000000 -0500 
@@ -1155,7 +1155,10 @@ static void defaultMachine(/*@out@*/ con 
 
            if ( pvr ) { 
                pvr >>= 16; 
-               if ( pvr >= 0x40) 
+               /* First, check for possible IBM750FX, 7410, 7450,  
7451, 7441, 7455, 7445 */ 
+               if ( (pvr == 0x7000 ) || (pvr == 0x8000) || (pvr == 
0x8001) || (pvr == 0x800c) ) 
+                 strcpy(un.machine, "ppc"); 
+               else if ( pvr >= 0x40) 
                    strcpy(un.machine, "ppcpseries"); 
                else if ( (pvr == 0x36) || (pvr == 0x37) ) 
                    strcpy(un.machine, "ppciseries");

Comment 1 Jeff Johnson 2006-01-27 08:14:31 UTC
Fixed in CVS, should be in rpm-4.4.5-0.8 when built.


Note You need to log in before you can comment on or make changes to this bug.