Bug 128605 - ppc64 gtk+ doesn't include gdk-pixbuf-query-loaders-64
ppc64 gtk+ doesn't include gdk-pixbuf-query-loaders-64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-26 19:48 EDT by Colin Walters
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-27 15:58:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Walters 2004-07-26 19:48:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040625 Epiphany/1.2.6

Description of problem:
I'm having trouble building libgnomeui on ppc64.  The reason is that
/etc/gtk-2.0/gdk-pixbuf.loaders is an empty file.

bash-2.05b# uname -a
Linux sizzler.build.redhat.com 2.4.21-15.EL #1 SMP Thu Apr 22 00:11:22
EDT 2004 ppc64 ppc64 ppc64 GNU/Linux
bash-2.05b# rpm -q --scripts gtk2
postinstall scriptlet (using /bin/sh):
/sbin/ldconfig
umask 022
/usr/bin/gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
/usr/bin/gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders
postuninstall scriptlet (using /bin/sh):
/sbin/ldconfig
if [ $1 = 0 ] ; then
        /bin/rm -f /etc/gtk-2.0/gtk.immodules
        /bin/rm -f /etc/gtk-2.0/gdk-pixbuf.loaders
fi
postinstall scriptlet (using /bin/sh):
/sbin/ldconfig
/usr/bin/update-gdk-pixbuf-loaders ppc64-redhat-linux
/usr/bin/update-gtk-immodules ppc64-redhat-linux
postuninstall scriptlet (using /bin/sh):
/sbin/ldconfig
postinstall scriptlet (using /bin/sh):
/sbin/ldconfig
/usr/bin/update-gdk-pixbuf-loaders ppc64-redhat-linux
/usr/bin/update-gtk-immodules ppc64-redhat-linux
postuninstall scriptlet (using /bin/sh):
/sbin/ldconfig
bash-2.05b# 


Now, the content of /usr/bin/update-gdk-pixbuf-loaders:

case "$host" in
  alpha*|ia64*|powerpc64*|s390x*|x86_64*)
   /usr/bin/gdk-pixbuf-query-loaders-64 >
/etc/gtk-2.0/$host/gdk-pixbuf.loaders

But since there is actually no /usr/bin/gdk-pixbuf-query-loaders-64,
/etc/gtk-2.0/gdk-pixbuf.loaders is empty.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
See above.
    

Additional info:

Note You need to log in before you can comment on or make changes to this bug.