Bug 1286051 - Unable to remove Dreamfactory from openshift marketplace online products
Unable to remove Dreamfactory from openshift marketplace online products
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Management Console (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Vu Dinh
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-27 05:18 EST by muralimenon.m
Modified: 2016-01-05 09:45 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-05 09:45:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
vdinh: needinfo+


Attachments (Terms of Use)
Error screenshot (54.33 KB, image/jpeg)
2015-11-27 05:18 EST, muralimenon.m
no flags Details

  None (edit)
Description muralimenon.m 2015-11-27 05:18:21 EST
Created attachment 1099628 [details]
Error screenshot

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Steps below

Steps to Reproduce:
1. Use RHC command to create the following Dreamfactory application
rhc app create dreamfactory http://cartreflect-claytondev.rhcloud.com/reflect?github=dreamfactorysoftware/dreamfactory-openshift-cartridge -s
2. Now there should be Dreamfactory product being shown in your openshift online products
3. Now use the rhc command to delete the dreamfactory application
4. Now try removing the Dreamfactory from your openshift products

Actual results:
You will now not be able to remove the Dreamfactory product from the list of products. You will not be able to view the product dashboard, or cancel the subscription.

Expected results:
Have Dreamfactory completely removed from my products list so that I can re-install it

Additional info:
I am totally stuck at this point. Any help will be greatly appreciated. I have attached screenshots and the actual error message. I am not even able to subscribe to the dreamfactory openshift support from the product page. Anyway that can be resolved at a later stage. For now I need to get Dreamfactory off the product list, without which I will not be able to install it correctly.

A similar problem (but with a different product - New Relic ) is discussed on bug report with ID: Bug 1145676
URL: https://bugzilla.redhat.com/show_bug.cgi?id=1145676
Comment 1 Vu Dinh 2015-12-17 16:20:37 EST
Hi,

I have been working on the issue that you brought to our attention. I would like to ask you for more details if you don't mind.

1. What tier are you using in OpenShift Online? Is it free/bronze/silver tier?

2. Did you add the DreamFactory cartridge from Marketplace to the list before you created the application? I have tried to reproduce the issue but the DreamFactory cartridge is not added in product list after I created the app and I'm not sure if it's supposed to do that either.

I would appreciate any details you can provide for this issue.

Thanks,
Vu
Comment 2 muralimenon.m 2016-01-04 15:46:19 EST
Sorry missed the earlier email requesting for more information
1) Openshift Plan: Bronze
2) I just created the application as per the rhc command I saw on github. It automatically added the product to marketplace products list.

P.N: Dreamfactory has released ver 2.x for openshift and I have been able to get that up and running without any issues. Thanks
Comment 3 Vu Dinh 2016-01-04 16:03:34 EST
Hi,

Thanks for the your response. So, from what you just mentioned above, I understand that the issue has been resolved in Dreamfactory 2.x. Is that correct? If so, I will close this bug since the issue no longer exists.

Thanks,
Vu
Comment 4 muralimenon.m 2016-01-04 23:40:25 EST
hi Vu,

With the new cartridges I have no issues so far. So I think it can be closed :-)

Thanks,
Murali
Comment 5 Vu Dinh 2016-01-05 09:45:59 EST
Hi Murali,

Thanks for the confirmation. The bug is now closed. Let's us know if you encounter any issues with OpenShift Online in the future.

Regards,
Vu

Note You need to log in before you can comment on or make changes to this bug.