Bug 1286200 - DHT:REBALANCE- statfs failures are seen during rebalance
DHT:REBALANCE- statfs failures are seen during rebalance
Status: CLOSED WORKSFORME
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribute (Show other bugs)
3.1
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Nithya Balachandran
Prasad Desala
dht-rebalance-file, dht-fops-while-re...
: ZStream
: 1286207 (view as bug list)
Depends On: 1028287
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-27 07:28 EST by Susant Kumar Palai
Modified: 2017-03-07 01:25 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1028287
Environment:
Last Closed: 2017-03-07 01:25:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Nithya Balachandran 2016-01-11 05:04:39 EST
*** Bug 1286207 has been marked as a duplicate of this bug. ***
Comment 3 krishnaram Karthick 2016-07-01 09:01:57 EDT
RCA:

dht_statfs_cbk should handle ENOENT/ESTALE errors just like dht_open_cbk/dht_stat_cbk as the file might've been moved out of the cached-subvol the client thinks.

regards,
Raghavendra
Comment 6 Prasad Desala 2017-02-01 02:42:53 EST
This issue still exists with glusterfs version: 3.8.4-13.el7rhgs.x86_64.

Steps:
1) Created a ganesha cluster and created a distributed-replicate volume.
2) Enabled nfs-ganesha on the volume with mdcache settings.
3) Mounted the volume on multiple clients.
4) Created files and folders.
5) From mount point, issued rm -rf * and started removing bricks.

During remove-brick rebalance, statfs failures are seen in rebalance logs.

ERROR SNIPPET in rebalance logs:
================================
[2017-02-01 06:45:27.197342] E [MSGID: 109023] [dht-rebalance.c:779:__dht_check_free_space] 0-distrep-dht: failed to get statfs of /2/linux-4.4.1/drivers/net/wireless/ath/ath5k/ani.h on distrep-replicate-2 (No such file or directory)
Comment 7 Nithya Balachandran 2017-02-01 03:51:24 EST
This is probably a valid scenario if the file is question was deleted just as the statfs was sent.

Do you see the issue with the steps listed in the description?
Comment 8 Prasad Desala 2017-03-06 12:04:13 EST
This issue is not reproduced on glusterfs version 3.8.4-15.el7rhgs.x86_64. Followed the same steps as in the description on both FUSE and NFS but the error reported in this BZ is not seen.

Note You need to log in before you can comment on or make changes to this bug.