Bug 1286283 - dmstats: support non-dm devices for stats create
dmstats: support non-dm devices for stats create
Status: CLOSED DUPLICATE of bug 1286282
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2 (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryn M. Reeves
cluster-qe@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-27 13:09 EST by Bryn M. Reeves
Modified: 2016-12-21 15:55 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-21 15:55:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryn M. Reeves 2015-11-27 13:09:42 EST
Description of problem:
Device-mapper IO statistics can be used with any block device providing a dm-linear layer is mapped over the underlying device, e.g.:

# dmsetup create sda --table="0 2048 linear 8:0"
# dmstats create sda
# < ... do stuff ... >
# dmstats delete sda
# dmsetup remove sda

Doing so is tedious and requires the user to have knowledge of device-mapper targets and table syntax.

By providing the ability to automatically create the linear map when required (and when the requested device is idle) the use of device-mapper statistics with non device-mapper devices is considerably simplified.

Version-Release number of selected component (if applicable):
lvm2-2.02.127-*.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. dmstats create /dev/sda

Actual results:
# dmstats create /dev/sda
Device sda not found
Command failed

Expected results:
* creates dm device "sda"
* registers requested stats regions on dm device "sda" 

Additional info:
Comment 2 Jonathan Earl Brassow 2016-12-21 15:55:16 EST

*** This bug has been marked as a duplicate of bug 1286282 ***

Note You need to log in before you can comment on or make changes to this bug.