Bug 128631 - No USB with 2.6 kernels, AMD756 chipset
No USB with 2.6 kernels, AMD756 chipset
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-27 09:29 EDT by oliver
Modified: 2015-01-04 17:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-20 17:58:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (14.52 KB, text/plain)
2004-07-27 09:30 EDT, oliver
no flags Details

  None (edit)
Description oliver 2004-07-27 09:29:38 EDT
Description of problem:

USB does not initialize properly, no USB device is usable.

Version-Release number of selected component (if applicable):

Tested with 2.6.6-1.435 (Fedora Core 2 updates) and 2.6.7-1.478
(Fedora Core 3 test 1, on an otherwise fully up-to-date Fedora Core 2
sytem)

How reproducible: Always


Steps to Reproduce: N/A
  
Actual results: 

USB does not work at all.  With the 2.6.6-1.435 kernel,
cat /proc/bus/usb/devices shows only the hub, any other device is not
registered (plugging devices in and out does not create syslog messages).

With 2.6.7-1.478, cat /proc/bus/usb/devices simply hangs.


Expected results: 
At least USB devices should register on the bus.  Devices have worked
on an older Redhat 8 system on the same machine.


Additional info:

Will attach /var/log/messages
Comment 1 oliver 2004-07-27 09:30:33 EDT
Created attachment 102223 [details]
/var/log/messages
Comment 2 oliver 2004-08-02 16:39:21 EDT
I should add that it's a Gigabyte GA-7IXE4 mainboard (AMD Irongate
Chip-Set). 

After some digging I found an old report in bugzilla which I filed
when some early 2.4 kernels broke USB on the same mainboard: 
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=49317

Comment 3 oliver 2004-10-05 16:04:29 EDT
Still no USB with Fedora Core Test 3 (2.6.8-1.541 kernel).
Comment 4 oliver 2005-03-01 14:11:58 EST
Problem solved with 2.6.10 kernels.
Comment 5 Dave Jones 2005-07-15 15:55:36 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 6 oliver 2005-07-20 17:58:13 EDT
As I was writing in comment #4, the problem has disappeared since kernel
2.6.10.  I have since upgraded to FC4, and everything is still working fine.
I think the bug can be closed.

Note You need to log in before you can comment on or make changes to this bug.