Bug 128636 - No MTRR for Xorg
No MTRR for Xorg
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-27 11:42 EDT by Tim Waugh
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 1.15.9-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-29 07:01:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2004-07-27 11:42:29 EDT
Description of problem:
No MTRR is set up for Xorg, since the write to /proc/mtrr is denied. 
This makes X *really* slow.

Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-6
selinux-policy-targeted-1.15.7-4

How reproducible:
100%

Steps to Reproduce:
1. Boot into runlevel 5.
  
Additional info:
I'm using an ATI Radeon 9800 XT on an AMD64.
Comment 1 Tim Waugh 2004-07-27 11:46:08 EDT
Oops, you need this:

audit(1090941629.012:0): avc:  denied  { write } for  pid=2124
exe=/usr/X11R6/bin/Xorg name=mtrr dev=proc ino=4026532079
scontext=user_u:system_r:unconfined_t
tcontext=system_u:object_r:mtrr_device_t tclass=file
Comment 2 Daniel Walsh 2004-07-28 11:00:58 EDT
Fixed in  selinux-policy-targeted-1.15.9-1
Comment 3 Tim Waugh 2004-07-29 07:01:40 EDT
Works here.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.