Bug 1286387 - java.lang.NoClassDefFoundError: org/antlr/runtime/CharStream
Summary: java.lang.NoClassDefFoundError: org/antlr/runtime/CharStream
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-pydev
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mat Booth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-11-28 21:22 UTC by Christian Stadelmann
Modified: 2015-12-07 20:30 UTC (History)
5 users (show)

Fixed In Version: eclipse-pydev-4.4.0-3.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-07 20:30:16 UTC


Attachments (Terms of Use)

Description Christian Stadelmann 2015-11-28 21:22:25 UTC
Description of problem:
When running eclipse-pydev I get thousands of these stacktraces printed to syslog:

Exception in thread "Thread-354" java.lang.NoClassDefFoundError: org/antlr/runtime/CharStream
at org.python.core.imp.compileSource(imp.java:373)
at org.python.core.imp.createFromSource(imp.java:388)
at org.python.core.imp.loadFromSource(imp.java:658)
at org.python.core.imp.find_module(imp.java:543)
at org.python.core.imp.import_next(imp.java:840)
at org.python.core.imp.import_first(imp.java:861)
at org.python.core.imp.load(imp.java:716)
at org.python.core.Py.importSiteIfSelected(Py.java:1558)
at org.python.util.PythonInterpreter.<init>(PythonInterpreter.java:116)
at org.python.util.PythonInterpreter.<init>(PythonInterpreter.java:94)
at org.python.pydev.jython.PythonInterpreterWrapperNotShared.<init>(PythonInterpreterWrapperNotShared.java:15)
at org.python.pydev.jython.JythonPlugin.newPythonInterpreter(JythonPlugin.java:618)
at org.python.pydev.builder.pep8.Pep8Visitor.getMessages(Pep8Visitor.java:134)
at com.python.pydev.analysis.OccurrencesAnalyzer$1.run(OccurrencesAnalyzer.java:46)
Caused by: java.lang.ClassNotFoundException: org.antlr.runtime.CharStream cannot be found by org.python.pydev.jython_4.4.0.201510221100
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:439)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:352)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:344)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:160)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
... 14 more


Additionally I sometimes get these stacktraces:

Exception in thread "PyEdit initializer" java.lang.NoClassDefFoundError: org/antlr/runtime/CharStream
at org.python.core.imp.compileSource(imp.java:373)
at org.python.core.imp.createFromSource(imp.java:388)
at org.python.core.imp.loadFromSource(imp.java:658)
at org.python.core.imp.find_module(imp.java:543)
at org.python.core.imp.import_next(imp.java:840)
at org.python.core.imp.import_first(imp.java:861)
at org.python.core.imp.load(imp.java:716)
at org.python.core.Py.importSiteIfSelected(Py.java:1558)
at org.python.util.PythonInterpreter.<init>(PythonInterpreter.java:116)
at org.python.util.PythonInterpreter.<init>(PythonInterpreter.java:94)
at org.python.util.PythonInterpreter.<init>(PythonInterpreter.java:71)
at org.python.pydev.jython.PythonInterpreterWrapper.<init>(PythonInterpreterWrapper.java:11)
at org.python.pydev.jython.JythonPlugin.newPythonInterpreter(JythonPlugin.java:616)
at org.python.pydev.jython.JythonPlugin.newPythonInterpreter(JythonPlugin.java:603)
at org.python.pydev.editor.scripting.PyEditScripting.createInterpreter(PyEditScripting.java:42)
at org.python.pydev.editor.scripting.PyEditScripting.<init>(PyEditScripting.java:37)
at org.python.pydev.editor.PyEdit$2.run(PyEdit.java:538)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.ClassNotFoundException: org.antlr.runtime.CharStream cannot be found by org.python.pydev.jython_4.4.0.201510221100
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:439)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:352)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:344)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:160)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
... 18 more


Version-Release number of selected component (if applicable):
eclipse-platform-4.5.1-4.fc23.x86_64
eclipse-pydev-4.4.0-2.fc23.x86_64
java-1.8.0-openjdk-1.8.0.65-3.b17.fc23.x86_64
ant-antlr-1.9.6-2.fc23.noarch
antlr-tool-2.7.7-37.fc23.noarch
antlr32-java-3.2-12.fc23.noarch (pulled in as dependency of jython)
antlr4-runtime-4.5-4.fc23.noarch

How reproducible:
Every time I start eclipse with pydev perspective open and edit python files

Actual results:
No directly visible bug, but probably some weird behavior.

Additional info:
/usr/share/java/antlr32/antlr-runtime-3.2.jar provided by antlr32-java contains a file /org/antlr/runtime/CharStream.class

The eclipse-pydev package does not depend on any antlr package according to spec %Requires

Comment 1 Mat Booth 2015-11-29 11:10:58 UTC
Hi,

Thanks for catching this in updates-testing before antlr32 update goes into stable.

You can downgrade your antlr32 packages to fix this:

  sudo dnf downgrade antlr32-\*

I will rebuild pydev to fix the broken symlink.

Comment 2 Fedora Update System 2015-11-29 12:11:47 UTC
antlr3-3.5.2-10.fc23 antlr32-3.2-12.fc23 eclipse-pydev-4.4.0-3.fc23 eclipse-xtext-antlr-generator-2.1.1-3.git18383dd.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-03f691b1fb

Comment 3 Fedora Update System 2015-11-29 12:11:47 UTC
antlr3-3.5.2-10.fc23 antlr32-3.2-12.fc23 eclipse-pydev-4.4.0-3.fc23 eclipse-xtext-antlr-generator-2.1.1-3.git18383dd.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-03f691b1fb

Comment 4 Fedora Update System 2015-11-29 23:53:25 UTC
antlr3-3.5.2-10.fc23, antlr32-3.2-12.fc23, eclipse-pydev-4.4.0-3.fc23, eclipse-xtext-antlr-generator-2.1.1-3.git18383dd.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update eclipse-pydev eclipse-xtext-antlr-generator antlr3 antlr32'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-03f691b1fb

Comment 5 Fedora Update System 2015-12-07 20:30:11 UTC
antlr3-3.5.2-10.fc23, antlr32-3.2-12.fc23, eclipse-pydev-4.4.0-3.fc23, eclipse-xtext-antlr-generator-2.1.1-3.git18383dd.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.