Bug 1286389 - yumex-dnf fails to update kernel-devel while dnf does
Summary: yumex-dnf fails to update kernel-devel while dnf does
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex-dnf
Version: 23
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-11-28 21:56 UTC by Alex Villacís Lasso
Modified: 2016-05-16 16:22 UTC (History)
8 users (show)

Fixed In Version: yumex-dnf-4.3.3-1.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-16 16:22:40 UTC
Type: Bug


Attachments (Terms of Use)

Description Alex Villacís Lasso 2015-11-28 21:56:18 UTC
Description of problem:

When trying to install kernel updates on a system that has kernel-devel installed, yumex-dnf does not offer kernel-devel as an update after resolving dependencies. On the same system, running "dnf update" from the command line does offer kernel-devel.


Version-Release number of selected component (if applicable):

dnf-1.1.4-1.fc23.noarch
yumex-dnf-4.1.4-1.fc23.noarch


How reproducible:
Always

Steps to Reproduce:
1. Have a system in need of a kernel update and install its matching kernel-devel, as well as yumex-dnf
2. Run yumex-dnf, select all the packages using the plus-labeled header
3. Click on the two-gear symbol to continue with the update

Actual results:
All kernel packages will be shown for update, except for kernel-devel

Expected results:
The kernel-devel should be shown as an available dependency

Additional info:

Comment 1 Mike Heller 2016-01-13 07:05:20 UTC
I noticed the same behavior on my systems.
pretty annoying.

Comment 2 Karl Latiss 2016-01-28 10:31:55 UTC
1. kernel-modules-extra is also missed
2. old kernel* RPMs do not get removed when yum.conf's installonly_limit has been reached

Comment 3 Woi 2016-02-02 13:45:19 UTC
I just reported the same issue upstream: https://github.com/timlau/yumex-dnf/issues/92

Comment 4 Allan 2016-03-18 07:24:23 UTC
I have the same problems with yumex-dnf .

It seems a 'work-around' is, after a new kernel have been found
and the usual other files missing, is to do a search for 'kernel-'.
That will show the other files in red. If you then clear the search
again, then Yumex-dnf will find all the kernel files (and others) in
the window.

Fedora 24 doesn't seem to come with Yumex(yum), which doesn't have this
problem, so TIM, please fix it.

Comment 5 Woi 2016-03-18 20:38:34 UTC
(In reply to Allan from comment #4)

> It seems a 'work-around' is, after a new kernel have been found
> and the usual other files missing, is to do a search for 'kernel-'.

Not really, because it misses to remove old kernel versions, as you can see with dnf update or in the above mentioned upstream bug.

Comment 6 Woi 2016-03-20 15:16:15 UTC
BTW: kernel-devel package is required for building akmod packages. According to <dnf search akmod> this affects support for Virtualbox, Nvidia closed source driver, some wifi cards and the embedded controller of some Thinkpads.
I stumbled upon this because my charging thresholds for Thinkpad batteries weren't working after a kernel update. This charging thresholds are used to reduce battery wear-out. So if one likes to put it extreme: This bug damages hardware.

Comment 7 Allan 2016-04-03 17:28:25 UTC
It seems that at least part of this bug has just been fixed in the yumex-dnf update, that has just arrived in F23 repo. I updated some other apps next day (no kernels), and then it suddenly cleaned up the old kernels.
Tried to enable updates-testing; but it still doesn't find kernel-devel

Comment 8 Woi 2016-04-09 15:36:10 UTC
I couldn't observe any improvement after the last yumex-dnf update.

Comment 9 Alex. H. F. 2016-04-28 17:14:25 UTC
Same problem here. No new version of yumex-dnf with improvements yet...

Comment 10 Allan 2016-04-29 16:05:12 UTC
If you have enabled 'cleanup old instonly packages'
it does remove the extra kernel packages here

Comment 11 Allan 2016-05-04 04:27:33 UTC
Here is another hint, I just discovered:
If you un-check the option: Show newest only
then Yumex will start showing _all_ the kernel
files, when you have new updates waiting to
be installed.

Comment 12 Tim Lauridsen 2016-05-09 10:58:19 UTC
This is a little tricky, there 2 modes to getting updates in yumex-dnf

1. like dnf update this will work with costs and repo priority etc.

2. show all available updates from all active repositories.

1 is default, but 2 can be enabled by unchecking "show newest only"

most of the time 1 is best, but in some cases 2 is usefull, I will work on getting it better, but there is many complex cases and it is very hard to test

Comment 13 Fedora Update System 2016-05-11 09:02:25 UTC
dnfdaemon-0.3.15-1.fc24 yumex-dnf-4.3.3-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-aa868f02e4

Comment 14 Fedora Update System 2016-05-12 09:41:28 UTC
dnfdaemon-0.3.15-1.fc24, yumex-dnf-4.3.3-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-aa868f02e4

Comment 15 Alex Villacís Lasso 2016-05-16 16:17:24 UTC
Please push to the Fedora 23 testing repository:

[root@avillacis ~]# dnf --enablerepo=updates-testing update dnfdaemon yumex-dnf
Fedora 23 - x86_64 - Test Updates                                                                                                                181 kB/s | 3.2 MB     00:18    
Última comprobación de caducidad de metadatos hecha hace 0:00:11, el Mon May 16 11:12:59 2016.
Dependencias resueltas.
Nada por hacer.
¡Listo!

Comment 16 Fedora Update System 2016-05-16 16:22:20 UTC
dnfdaemon-0.3.15-1.fc24, yumex-dnf-4.3.3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.