Bug 128640 - portmap has SIGCHLD set to SIG_IGN but calls wait()
Summary: portmap has SIGCHLD set to SIG_IGN but calls wait()
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: portmap (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Jay Turner
URL:
Whiteboard: RHEL3U7NAK
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-27 16:47 UTC by Marc Schmitt
Modified: 2015-01-08 00:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-02 20:29:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marc Schmitt 2004-07-27 16:47:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
The portmapper under RHEL3 AS (2.4.21-15.0.3.EL, probably WS, too)
appears to have a problem:

Jul 27 15:55:51 foo kernel: application bug: portmap(21231) has
SIGCHLD set to SIG_IGN but calls wait().
Jul 27 15:57:00 foo kernel: application bug: portmap(21231) has
SIGCHLD set to SIG_IGN but calls wait().
Jul 27 15:58:04 foo kernel: application bug: portmap(21231) has
SIGCHLD set to SIG_IGN but calls wait().
Jul 27 16:01:36 foo kernel: application bug: portmap(21231) has
SIGCHLD set to SIG_IGN but calls wait().

I don't know what triggers those lines and I don't notice any problems
with the machine, either. The portmapper appears to work fine.

The output of `rpcinfo -p` looks like this:
   program vers proto   port
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper
    391002    2   tcp  32769  sgi_fam
    100024    1   udp  47544  status
    100024    1   tcp  59745  status
    100011    1   udp    684  rquotad
    100011    2   udp    684  rquotad
    100011    1   tcp    687  rquotad
    100011    2   tcp    687  rquotad
    100003    2   udp   2049  nfs
    100003    3   udp   2049  nfs
    100003    2   tcp   2049  nfs
    100003    3   tcp   2049  nfs
    100021    1   udp  47547  nlockmgr
    100021    3   udp  47547  nlockmgr
    100021    4   udp  47547  nlockmgr
    100021    1   tcp  59747  nlockmgr
    100021    3   tcp  59747  nlockmgr
    100021    4   tcp  59747  nlockmgr
    100005    1   udp    726  mountd
    100005    1   tcp    729  mountd
    100005    2   udp    726  mountd
    100005    2   tcp    729  mountd
    100005    3   udp    726  mountd
    100005    3   tcp    729  mountd

I found only one similar problem
(http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=117333) and
judging by the comment of Chip Turner I thought I'd post this issue here.

Version-Release number of selected component (if applicable):
portmap-4.0-56

How reproducible:
Didn't try


Additional info:

Let me know if you need any other information. Thanks.

Comment 1 Steve Dickson 2004-08-12 17:06:22 UTC
This appears to be fixed in the latest release by
this code:

#ifdef IGNORE_SIGCHLD           /* Lionel Cons <cons@dxcern.cern.ch> */
    (void)signal(SIGCHLD, SIG_IGN);
#else
    (void)signal(SIGCHLD, reap);
#endif

with reap() doing the wait3() which will not called if IGNORE_SIGCHLD 
is set.

Comment 21 Steve Dickson 2006-05-02 20:29:59 UTC
After further review it appears code is there but... the compile flag
IGNORE_SIGCHLD is not being set... and I really don't want to
turn it on at this late stage of the release cycle...  So I'm
closing  this as WONTFIX... 


Note You need to log in before you can comment on or make changes to this bug.