Bug 1286415 - Engine setup failed to clean async commands
Engine setup failed to clean async commands
Status: CLOSED NOTABUG
Product: ovirt-engine
Classification: oVirt
Component: Setup.Engine (Show other bugs)
3.6.0.2
Unspecified Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: Sandro Bonazzola
Pavel Stehlik
integration
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-29 04:35 EST by Eyal Shenitzky
Modified: 2015-12-01 07:38 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-01 07:38:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
eshenitz: planning_ack?
eshenitz: devel_ack?
eshenitz: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Eyal Shenitzky 2015-11-29 04:35:31 EST
Description of problem:

When trying to run engine-setup command (update the engine to 3.6.0-22 version)
Setup trying to  "Cleaning async tasks and compensations" and failed to terminate the async commands.

[ INFO  ] Cleaning async tasks and compensations
          The following system tasks have been found running in the system:
          The following commands have been found running in the system:
          Command ID:           b641b00b-1332-4237-9370-f16d7d3339c5
          Command Type:                                   3207
          Created at:           30
          Status:               FAILED_RESTARTED              
          The following compensations have been found running in the system:
          Would you like to try to wait for that?




Version-Release number of selected component (if applicable):
rhevm -3.6.0.3-0.1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. update repo to http://bob.eng.lab.tlv.redhat.com/builds/3.6/3.6.0-22/el$releasever

2. run yum update
3. run engine-setup

Actual results:
Engine setup failed to clean async commands.

Expected results:
ngine setup successfully clean async commands.

Additional info:

previous related bug-
https://bugzilla.redhat.com/show_bug.cgi?id=1161012
Comment 1 Yedidyah Bar David 2015-11-29 04:47:25 EST
(In reply to eyal shenitzky from comment #0)
> Expected results:
> ngine setup successfully clean async commands.

Why?

Why not wait?

You might claim, and I'll agree, that more info should be provided, perhaps more options (not sure which).
Comment 2 Eyal Shenitzky 2015-12-01 06:53:47 EST
I wait for a long time (approximately 15-20 min),

Maybe stop the command with force option.
Comment 3 Sandro Bonazzola 2015-12-01 07:38:30 EST
Closing as not a bug. for clearing pending task see  bug #879248.

Note You need to log in before you can comment on or make changes to this bug.