Bug 1286427 - Network labels : wrong labels link appear on a _label_ resource - confusing to the user on how to remove label via REST API
Network labels : wrong labels link appear on a _label_ resource - confusing t...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
3.6.1
x86_64 Linux
high Severity medium (vote)
: ovirt-3.6.2
: 3.6.1.2
Assigned To: Yevgeny Zaspitsky
Meni Yakove
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-29 06:28 EST by Ori Ben Sasson
Modified: 2016-03-26 11:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:11:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: blocker+
ylavi: planning_ack+
danken: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 49382 master MERGED restapi: change "vf" to "virtualfunction" Never
oVirt gerrit 49452 ovirt-engine-3.6 MERGED restapi: change "vf" to "virtualfunction" Never
oVirt gerrit 49454 ovirt-engine-3.6.1 MERGED restapi: change "vf" to "virtualfunction" Never
oVirt gerrit 49471 master MERGED restapi: Fix labels/virtualfunctionallowedlabels href Never
oVirt gerrit 49472 ovirt-engine-3.6.1 MERGED restapi: Fix labels/virtualfunctionallowedlabels href Never
oVirt gerrit 49476 ovirt-engine-3.6 MERGED restapi: Fix labels/virtualfunctionallowedlabels href Never
oVirt gerrit 49571 master ABANDONED restapi: Separate label services 2016-03-26 11:15 EDT

  None (edit)
Description Ori Ben Sasson 2015-11-29 06:28:22 EST
Description of problem:
It's impossible to remove label from NIC with rest API 
in the following link 10.35.163.37/ovirt-engine/api/hosts/d5447a3d-8c4e-40da-9800-dfdcf24de680/nics/b8b37881-fa63-4ed5-a76d-8a695f8c5fb7/virtualfunctionallowedlabels/label_0 ,i try to delete label and i couldn't. probably because adding virtualfunctionallowedlabels function. 
Manually it's possible to remove label from host NIC

Version-Release number of selected component (if applicable):
rhevm-3.6.1-0.2.el6.noarch

How reproducible:
100

Steps to Reproduce:
1.Attach label to host NIC
2.Remove label from host NIC

Actual results:
Its impossible to remove label from host NIC 

Expected results:
should be possible to remove label from host NIC
Comment 1 Red Hat Bugzilla Rules Engine 2015-11-29 06:56:54 EST
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 2 Yevgeny Zaspitsky 2015-11-29 07:34:37 EST
1. The bug does not reproduce on my env.
2. On the QA env if we use the right URL 10.35.163.37/ovirt-engine/api/hosts/d5447a3d-8c4e-40da-9800-dfdcf24de680/nics/b8b37881-fa63-4ed5-a76d-8a695f8c5fb7/labels/label_0 (note the difference: "labels" instead of "virtualfunctionallowedlabels") everything works. So the bug is about wrong labels link appears on a NIC resource rather than "It's impossible to remove label from NIC with rest API".
Comment 3 Yevgeny Zaspitsky 2015-11-29 07:44:37 EST
Correction to my last comment:
The bug is about wrong labels link appears on a _label_ resource.
Comment 4 Ori Ben Sasson 2015-12-29 03:06:43 EST
Verified on 3.6.2-0.1.el6

Note You need to log in before you can comment on or make changes to this bug.