Bug 128650 - Neomagic 256AV only allowed 800x600 resolution
Summary: Neomagic 256AV only allowed 800x600 resolution
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Keywords:
: 134653 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-27 18:12 UTC by Tim Waugh
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-15 11:25:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
system-config-display-depth.patch (1.16 KB, patch)
2004-10-14 17:03 UTC, Tim Waugh
no flags Details | Diff

Description Tim Waugh 2004-07-27 18:12:13 UTC
Description of problem:
I'm pretty sure this worked in Fedora Core 2.  On this Dell Inspiron
3500, equipped with Neomagic 256AV and a 1024x768 LCD display, I can't
get system-config-display to let me use anything other than 640x480 or
800x600.  I have set the monitor to LCD 1024x768.

Version-Release number of selected component (if applicable):
hwdata-0.123-1

Comment 1 Bill Nottingham 2004-07-27 19:45:54 UTC
Does it work if you set it at that resolution by hand?

What's the output of 'kudzu -p -b ddc'?

Comment 2 Tim Waugh 2004-07-28 08:32:35 UTC
Yes, it works fine if I edit xorg.conf and add "1024x768" to the right
places.

[root@eagle root]# kudzu -p -b ddc
-
class: VIDEO
bus: DDC
detached: 0
driver: unknown
desc: "NeoMagic MagicMedia 256 AV"
mem: 2496


Comment 3 Bill Nottingham 2004-07-28 16:50:53 UTC
Hm, I wonder if that's failing the mode calc for memory.

Comment 4 Jeremy Katz 2004-07-28 21:37:14 UTC
That would make sense to me

Comment 5 Paul Nasrat 2004-10-06 07:20:25 UTC
*** Bug 134653 has been marked as a duplicate of this bug. ***

Comment 6 Tim Waugh 2004-10-14 17:02:15 UTC
This is due to there being no callback from the colour depth option
menu to add resolutions to the resolution option menu.  Patch to follow..

Comment 7 Tim Waugh 2004-10-14 17:03:01 UTC
Created attachment 105210 [details]
system-config-display-depth.patch

Comment 8 Paul Nasrat 2004-10-14 17:25:59 UTC
Thanks, looks correct.  Applied and built in 1.0.22 

Comment 9 Tim Waugh 2004-10-15 11:25:12 UTC
1.0.22-1 works for me.

Comment 10 David Susco 2006-04-19 21:10:07 UTC
I'm having a similar problem with a Dell CPi A366ST (Service Tag: LT133X1).

I have my resolution set to 1024x768, color depth to 16 but everytime X restarts
it reverts to 800x600 and the depth stays the same.  By default the monitor type
is "unknown monitor" I have tried setting this to "Dell 1024x768 LCD" but no
luck there either.

Here's another weird thing though, I purposely broke the xorg.conf by enabling
dual head.  X generated a new .conf and gave me the system-config-display and
everything appeared to be 1024x768.  Then when X restarted again and I got
dumped back to the login screen 800x600 came back again.

system-config-display is 1.0.24

kudzu -p -b ddc
-
class: VIDEO
bus: DDC
detached: 0
driver: unknown
desc: "NeoMagic MagicMedia 256 AV"
mem: 2496

(In reply to comment #0)
> Description of problem:
> I'm pretty sure this worked in Fedora Core 2.  On this Dell Inspiron
> 3500, equipped with Neomagic 256AV and a 1024x768 LCD display, I can't
> get system-config-display to let me use anything other than 640x480 or
> 800x600.  I have set the monitor to LCD 1024x768.
> 
> Version-Release number of selected component (if applicable):
> hwdata-0.123-1




Note You need to log in before you can comment on or make changes to this bug.