Bug 1286653 - linear->raid1 conversion possible, but reported as not supported
linear->raid1 conversion possible, but reported as not supported
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alasdair Kergon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 07:12 EST by Vratislav Podzimek
Modified: 2015-11-30 17:37 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-30 17:37:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of 'lvconvert -vvvv --type=raid1 data/test' (23.19 KB, text/plain)
2015-11-30 11:31 EST, Vratislav Podzimek
no flags Details

  None (edit)
Description Vratislav Podzimek 2015-11-30 07:12:48 EST
Description of problem:
'lvconvert --type=raid1 -m1' reports that the conversion is not supported yet, but running 'lvconvert --type=mirror -m1' followed by 'lvconvert --type=raid1' works just fine. LVM could just do these two steps on its own or at least suggest user that something like that is possible.

Version-Release number of selected component (if applicable):
lvm2-2.02.132-2.fc23.x86_64

How reproducible:
100%

Steps to Reproduce:
1. have a linear LV
2. run 'lvconvert --type=raid1 -m1 theLV'

Actual results:
LVM complains about the conversion not being supported yet

Expected results:
conversion done because it's possible or at least a workaround being suggested
Comment 1 Alasdair Kergon 2015-11-30 09:45:17 EST
Works for me.

If you still think there's a problem, please provide complete data i.e. actual output from the commands with -vvvv added.
Comment 2 Vratislav Podzimek 2015-11-30 11:30:31 EST
Oh, it only happens if I omit the '-m1' option. I'm not sure if it is a mandatory option, but if it is, the error message should be something else than "Converting the segment type for data/test from linear to raid1 is not yet supported.".
Comment 3 Vratislav Podzimek 2015-11-30 11:31 EST
Created attachment 1100548 [details]
output of 'lvconvert -vvvv --type=raid1 data/test'
Comment 4 Alasdair Kergon 2015-11-30 17:32:04 EST
OK - I'll put '--type raid' into the same category as mirror.

(We are doing a thorough review and extension of this code at the moment to allow many more types of conversions.)

Note You need to log in before you can comment on or make changes to this bug.