Bug 1286658 - 'Uncaught exception occurred' message when removing a VM while Snapshots sub-tab selected
'Uncaught exception occurred' message when removing a VM while Snapshots sub-...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.1
: 3.6.1.1
Assigned To: Daniel Erez
Natalie Gavrielov
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 07:33 EST by Daniel Erez
Modified: 2016-02-10 12:17 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 08:28:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tnisan: ovirt‑3.6.z?
tnisan: blocker?
rule-engine: planning_ack?
tnisan: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 49433 master MERGED webadmin: prevent an npe on VmSnapshotListModel Never
oVirt gerrit 49434 master MERGED webadmin: prevent IndexOutOfBounds on VmSnapshotList Never
oVirt gerrit 49447 ovirt-engine-3.6 MERGED webadmin: prevent an npe on VmSnapshotListModel Never
oVirt gerrit 49448 ovirt-engine-3.6 MERGED webadmin: prevent IndexOutOfBounds on VmSnapshotList Never
oVirt gerrit 49456 ovirt-engine-3.6.1 MERGED webadmin: prevent IndexOutOfBounds on VmSnapshotList Never
oVirt gerrit 49457 ovirt-engine-3.6.1 MERGED webadmin: prevent an npe on VmSnapshotListModel Never

  None (edit)
Description Daniel Erez 2015-11-30 07:33:14 EST
Description of problem:
When removing a VM while Snapshots sub-tab is selected, an 'Uncaught exception occurred' message is displayed in the webadmin.

Version-Release number of selected component (if applicable):
3.6

Steps to Reproduce:
1. Create a VM -> add a disk -> create a Snapshot.
2. Navigate to Snapshots sub-tab.
3. Remove the VM.

Actual results:
'Uncaught exception occurred' message is displayed.

Expected results:
Should be cleanly removed.
Comment 1 Red Hat Bugzilla Rules Engine 2015-11-30 07:43:20 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Red Hat Bugzilla Rules Engine 2015-11-30 07:43:20 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 3 Red Hat Bugzilla Rules Engine 2015-11-30 07:46:01 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 4 Sandro Bonazzola 2015-12-01 10:07:02 EST
This bug is referenced in git log for ovirt-engine-3.6.1.1.
Please set target release to 3.6.1.1 accordingly unless additional patches are needed.
Comment 5 Natalie Gavrielov 2015-12-16 07:34:15 EST
Verified using rhevm-3.6.1.3-0.1.el6.noarch (build 3.6.1-4)

Used the scenario described in comment #1
1. Create a VM -> add a disk -> create a Snapshot.
2. Navigate to Snapshots sub-tab.
3. Remove the VM.

VM is removed, no exceptions found.
Comment 6 Sandro Bonazzola 2015-12-22 08:28:26 EST
oVirt 3.6.1 has been released and bz verified, moving to closed current release

Note You need to log in before you can comment on or make changes to this bug.