Bug 1286721 - Only files of size up to 8 GB can be archived by cpio, Ticket #37453
Only files of size up to 8 GB can be archived by cpio, Ticket #37453
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cpio (Show other bugs)
6.4
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Pavel Raiskup
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 10:15 EST by alsanche
Modified: 2015-12-01 02:04 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-01 01:47:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description alsanche 2015-11-30 10:15:17 EST
Description of problem:


Version-Release number of selected component (if applicable): 

cpio-2.10-11.el6_3.i686 and cpio-2.6-23.el5_4.1


How reproducible: 

As per the customer: 
I searched online and I found out that users are having this issue more and more for the last 3 years.

For us it arise last year when one of our files reach 4Gb but we manage to go around by using

cpio -o -H odc > /dev/sdc

Now, our file reach the max size of 8 GB and cpio doesn't work anymore

We need to be able to use a command that allow us to restore one file at the time like cpio


Steps to Reproduce:
1. cpio -o -H odc > /dev/sdc


Actual results:

our file reach the max size of 8 GB and cpio doesn't work anymore

Expected results:

file should be backed up using cpio command

Additional info:

As per the customer:

We have several clients with files larger than 6GB and they are currently not being backed up because of this bug.

If you look at the internet search, you will also find numerous users with exactly the same problem.
Comment 2 Pavel Raiskup 2015-12-01 01:47:03 EST
(In reply to alsanche from comment #0)
> Now, our file reach the max size of 8 GB and cpio doesn't work anymore

This is expected -- the formats supported by GNU cpio have limits.  There is
not much we can do about it (except adding new format into cpio, which is not
much realistic because cpio interface is legacy these days).

> We need to be able to use a command that allow us to restore one file at the
> time like cpio

As you say namely _restore_ one file at a time, I would suggest you to use GNU
tar; for example this command for archive creation:

  $ tar --posix -cf archive -T -

Note that the file specified by '-T' is not used as stream on RHEL-6, thus
the archive is create once _whole file_ has been read.  Then you can restore
one file from the archive:

  $ tar -xf archive FILE

Pavel

Note You need to log in before you can comment on or make changes to this bug.