Bug 1286734 - How to migrate from 3.0 clustering (pacemaker) to native 3.1 clustering
How to migrate from 3.0 clustering (pacemaker) to native 3.1 clustering
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
urgent Severity medium
: ---
: ---
Assigned To: Alex Dellapenta
Miheer Salunke
Vikram Goyal
:
: 1287155 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 10:49 EST by Miheer Salunke
Modified: 2016-07-15 11:03 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-15 11:03:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miheer Salunke 2015-11-30 10:49:48 EST
Document URL: 
https://docs.openshift.com/enterprise/3.1/install_config/install/advanced_install.html#multiple-masters

https://docs.openshift.com/enterprise/3.1/install_config/upgrades.html

Section Number and Name: 

Multiple Masters Using Native HA


Describe the issue: 

The update documentation (https://docs.openshift.com/enterprise/3.1/install_config/upgrades.html) doesn't cover how to migrate from the 3.0 clustering technique (using pacemaker) to the native one included in 3.1


Suggestions for improvement: 
Please add the upgrade steps for migrating from the 3.0 clustering technique (using pacemaker) to the native one included in 3.1

Additional information:
Comment 1 Jason DeTiberus 2015-11-30 10:53:14 EST
Andrew should be able to fill in the details needed for the conversion from the engineering side.
Comment 5 Vikram Goyal 2016-01-21 00:58:41 EST
*** Bug 1287155 has been marked as a duplicate of this bug. ***
Comment 8 Alex Dellapenta 2016-02-09 16:29:04 EST
WIP PR: https://github.com/openshift/openshift-docs/pull/1567
Comment 9 Alex Dellapenta 2016-02-09 17:28:24 EST
Closed the PR from comment 8, continuing in https://github.com/openshift/openshift-docs/pull/1568 instead (breaking up the Upgrading topic into a subdir w/ multiple topics now).
Comment 11 Anping Li 2016-02-22 20:58:08 EST
Verified and pass. The new document steps works well.
Comment 12 openshift-github-bot 2016-02-23 15:46:31 EST
Commit pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/5c1a08637a8d6d21304af1d0ed9a251f6cf614a7
Merge pull request #1568 from adellape/breakup_upgrading

Bug 1286734: Breakup Upgrading into subdir, add pacemaker_to_native_ha

Note You need to log in before you can comment on or make changes to this bug.