Bug 1286893 - [DOCS] [openshift-doc] Need documentation of container log rotation with json-file options
[DOCS] [openshift-doc] Need documentation of container log rotation with json...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Ashley Hardin
Vikram Goyal
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 22:18 EST by Kenjiro Nakayama
Modified: 2016-02-15 11:35 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-15 11:35:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenjiro Nakayama 2015-11-30 22:18:19 EST
Description of problem:
- Docker 1.8.2 has the function to manage json-file logs. http://docs.docker.com/engine/reference/logging/overview/#the-json-file-options
- It should included in OSEv3 docs as well.


Document URL: 
- https://docs.openshift.com/enterprise/3.1/install_config/index.html


Section Number and Name: 
- The section of container log rotation should be inserted before/after 
Aggregating Container Logs section.


Suggestions for improvement: 
(Ref)  http://docs.docker.com/engine/reference/logging/overview/#the-json-file-options
(Ref) https://access.redhat.com/solutions/2064433


Additional information: 
- This ticket has been forked from https://bugzilla.redhat.com/show_bug.cgi?id=1252648#c19
Comment 1 Kenjiro Nakayama 2016-01-19 00:57:43 EST
There are two sections to update. 

1. As I mentioned above, it should be added in the log section.(insert before/after Aggregating Container Logs section.)

2. Update advance installation section (https://docs.openshift.com/enterprise/3.1/install_config/install/advanced_install.html), since ansible installer can set the log option.

As for #2, I filed to github openshift-docs as well. - ref. https://github.com/openshift/openshift-docs/issues/1447
Comment 3 Ashley Hardin 2016-01-28 16:10:00 EST
PR created (WIP): https://github.com/openshift/openshift-docs/pull/1495

Please take a look and offer suggestions. Thanks!
Comment 4 Kenjiro Nakayama 2016-02-01 23:08:16 EST
I will re-review after you update from current review. (I am dropping need-info now.)
Comment 5 openshift-github-bot 2016-02-11 17:06:11 EST
Commits pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/37817d38437ac2377c47eaecde2ad2ba2ea602b0
Bug 1286893, added info on container log rotation with json-file options

https://github.com/openshift/openshift-docs/commit/e81abaac30ce4279594c0e66c8b0a60e2b11f18b
Merge pull request #1495 from ahardin-rh/docker-log

Bug 1286893, added info on container log rotation with json-file options
Comment 6 Ashley Hardin 2016-02-11 17:25:43 EST
Several rounds of edits are complete. Please reopen if further changes are needed.

Note You need to log in before you can comment on or make changes to this bug.